Support » Plugin: Jetpack - WP Security, Backup, Speed, & Growth » Jetpack 9.2.1 breaks Classic Editor

  • Resolved dpmickle

    (@dpmickle)


    System Information:
    PHP: 7.3.23
    Database: mysqli 10.2.36-MariaDB-log
    WordPress:5.6
    JetPack: 9.2.1:1607631432
    Classic Editor Plus: 1.0.4
    ——-
    Hello All,

    Ever since JetPack upgraded to 9.2.1 the site a few days ago, the editor has been broken. I can not enter text, links, etc. Most times, nothing will show on the “Visual” tab until I click the text tab, then come back to the visual tab. I know that problem has been mention in other forums. I even tried a different plugin for the classic editor with the same results.

    As soon as I deactivate JetPack, everything functions again. Am I missing something or is this just a bug that will eventually be fixed?

    Thank you in advance!
    Dan

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support Karen Attfield

    (@wpkaren)

    Hi @dpmickle

    It looks like you are using the Classic Editor Plus plugin, so it sounds like there may be a conflict between that plugin and the latest version of Jetpack. What we’d suggest in that case is reaching out to that plugin author to explain the issue you are seeing.

    What I would recommend is using the official Classic Editor plugin instead: https://wordpress.org/plugins/classic-editor/

    You did mention you’d tried a different Classic Editor plugin – was it the official plugin or another? If you did try that plugin with no luck, could you please look in the browser tools, in the “Console” tab for any JavaScript errors?

    You can take a screenshot of the entire console and share the image here using a tool such as https://snipboard.io/. Thank you!

    Thread Starter dpmickle

    (@dpmickle)

    Hi Karen,

    Thank you for the response. To answer your question, I did start with the official classic editor. I moved to this current one to see if the classic editor was the issue. I had the same error happen with both editors. That is when I went one by one and activated each plug-in, and finally found it was JetPack causing the issue. The site with all other plug-ins enabled works, as long as JetPack is off. This issue is also happening on 5 other sites I maintain. 3 of which are on a completely different server/provider.

    Here is the console log (screen shot)

    JQMIGRATE: Migrate is installed, version 3.3.2
    autocomplete.min.js:9
    Uncaught TypeError: this._addClass is not a function
    at $.<computed>.<computed>._create (autocomplete.min.js:9)
    at $.<computed>.<computed>._create (jquery-ui.js:415)
    at $.<computed>.<computed>._createWidget (jquery-ui.js:585)
    at new $.<computed>.<computed> (jquery-ui.js:376)
    at HTMLInputElement.<anonymous> (jquery-ui.js:531)
    at Function.each (jquery.min.js:2)
    at s.fn.init.each (jquery.min.js:2)
    at s.fn.init.$.fn.<computed> [as autocomplete] (jquery-ui.js:523)
    at i.onPostRender (/wp-includes/js/tinymce/plugins/wplink/plugin.min.js?wp-mce-49110-20201110:1)
    at i.a (plugin.min.js:1)
    at vp.c.fire (tinymce.min.js:2)
    at i.fire (/wp-includes/js/tinymce/themes/modern/theme.min.js?wp-mce-49110-20201110:1)
    at i.postRender (/wp-includes/js/tinymce/themes/modern/theme.min.js?wp-mce-49110-20201110:1)
    at i.<anonymous> (/wp-includes/js/tinymce/themes/modern/theme.min.js?wp-mce-49110-20201110:1)
    at Object.jt [as each] (tinymce.min.js:2)
    at i.each (/wp-includes/js/tinymce/themes/modern/theme.min.js?wp-mce-49110-20201110:1)
    at i.exec (/wp-includes/js/tinymce/themes/modern/theme.min.js?wp-mce-49110-20201110:1)
    at i.postRender (/wp-includes/js/tinymce/themes/modern/theme.min.js?wp-mce-49110-20201110:1)
    at i.postRender (tinymce.min.js:2)
    at i.<anonymous> (/wp-includes/js/tinymce/themes/modern/theme.min.js?wp-mce-49110-20201110:1)
    at Object.jt [as each] (tinymce.min.js:2)
    at i.each (/wp-includes/js/tinymce/themes/modern/theme.min.js?wp-mce-49110-20201110:1)
    at i.exec (/wp-includes/js/tinymce/themes/modern/theme.min.js?wp-mce-49110-20201110:1)
    at i.postRender (/wp-includes/js/tinymce/themes/modern/theme.min.js?wp-mce-49110-20201110:1)
    at i.postRender (tinymce.min.js:2)
    at i.postRender (/wp-includes/js/tinymce/themes/modern/theme.min.js?wp-mce-49110-20201110:1)
    at i.postRender (tinymce.min.js:2)
    at i.<anonymous> (/wp-includes/js/tinymce/themes/modern/theme.min.js?wp-mce-49110-20201110:1)
    at Object.jt [as each] (tinymce.min.js:2)
    at i.each (/wp-includes/js/tinymce/themes/modern/theme.min.js?wp-mce-49110-20201110:1)
    at i.exec (/wp-includes/js/tinymce/themes/modern/theme.min.js?wp-mce-49110-20201110:1)
    at i.postRender (/wp-includes/js/tinymce/themes/modern/theme.min.js?wp-mce-49110-20201110:1)
    at i.postRender (tinymce.min.js:2)
    at i.renderTo (/wp-includes/js/tinymce/themes/modern/theme.min.js?wp-mce-49110-20201110:1)
    at Object.g.wp._createToolbar (/wp-includes/js/tinymce/plugins/wordpress/plugin.min.js?wp-mce-49110-20201110:1)
    at tN.<anonymous> (/wp-includes/js/tinymce/plugins/wplink/plugin.min.js?wp-mce-49110-20201110:1)
    at vp.c.fire (tinymce.min.js:2)
    at tN.fire (tinymce.min.js:2)
    at bw (tinymce.min.js:2)
    at ww (tinymce.min.js:2)
    at Aw (tinymce.min.js:2)
    at tN.<anonymous> (tinymce.min.js:2)
    at Array.<anonymous> (tinymce.min.js:2)
    at jt (tinymce.min.js:2)
    at u (tinymce.min.js:2)
    at n (tinymce.min.js:2)
    at HTMLScriptElement.l.<computed>.l.<computed>.l.<computed>.o.onload (tinymce.min.js:2)

    Plugin Support Dat Hoang

    (@htdat)

    Thanks for your response.

    In your screenshot https://snipboard.io/kwlLej.jpg, many other plugins are still active. Can you please double check again when only Jetpack is active?

    at i.onPostRender (/wp-includes/js/tinymce/plugins/wplink/plugin.min.js?wp-mce-49110-20201110:1)
    at i.<anonymous> (/wp-includes/js/tinymce/themes/modern/theme.min.js?wp-mce-49110-20201110:1)

    From your error, there is no sign of Jetpack. Instead, plugin wplink and theme modern are involved in this error.

    I am not able to replicate the issue with:

    – Theme: Storefront
    – Plugin: Classic Editor 1.6
    – Plugin: Jetpack 9.2.1
    – And a few other common plugins: AMP, WooCommerce, Email Log.

    Here is what it’s showing on my site https://d.pr/i/GFPvGP

    Thread Starter dpmickle

    (@dpmickle)

    I found this issue. It seems there was a corruption in the theme update. It was oddly only affecting the site when JetPack was enabled. I did a fresh/manual update of the theme and things are working.

    Strange as there was no error or warning, and everything else on the site worked perfectly, except JetPack.

    Thanks for the help and for letting me “walk through it” out loud.

    Dan

    Plugin Support Dat Hoang

    (@htdat)

    Strange as there was no error or warning, and everything else on the site worked perfectly, except JetPack.

    It’s probably that the theme you used to load something from Jetpack.

    Anyway, that’s awesome! Glad to hear that you’re able to fix the issue.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Jetpack 9.2.1 breaks Classic Editor’ is closed to new replies.