Support » Plugin: Jetpack by WordPress.com » Jetpack 5.2.1 + WP 4.8.1 is incompatible with PHP 5.3.28

  • Resolved Tim Smith

    (@creativeinfusion)



    Jetpack 5.2.1

    Site gives a 500 Internal server error which is caused by an “End of script output before headers: index.php”.

    Deactivating Jetpack stopped the problem, reactivating it caused it again.

    Changing to PHP 5.6.31 fixed the issue, so there must be an incompatibility problem.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Tim Smith

    (@creativeinfusion)

    Just to clarify only the front end of the site was effected, the admin still loaded normally.

    Wonder if that could cause problems on php 5.5 also?

    Hi @creativeinfusion – What PHP version were you running previously? 5.6 is a safe version to be on, we have seen some compatibility issues with older versions (pre 5.3).

    @ebhead – Are you having the same issues? If so can you please do try the same and upgrade to 5.6?

    Tim Smith

    (@creativeinfusion)

    Hi @lamdayap – as it says in the title PHP version 5.3.28

    I was aware of some earlier issues which is why I upgraded to 5.6, but hadn’t seen this specific issue mentioned (is there a trac for Automatic plugins?). Upgrading also may not be an option for everyone.

    • This reply was modified 1 year, 6 months ago by  Tim Smith.

    Hi @creativeinfusion,

    Sorry about that! The PHP conflicts haven’t been reproduced by our team and we’ve even seen some users fix the issue simply by refreshing their page a few times, however we do have an open report of this and are tracking it internally.

    Happening to me too. Cant change PHP version, so have to uninstall Jetpack. Its best to include backward compatibility in plugins and not just switch to code only supported with higher PHP, or include something that prevents plugin updates unless you have a supported PHP, as it results in websites going down. Upgrading PHP is not a simple task for some, and should not be a solution! Thanks.

    Sandy J

    (@sandyjuettner242)

    Agree with @amityweb. Same problem here on about 15 sites on multiple servers. Have had to roll back to Jetpack 5.0 and turn off automatic updates on all sites.

    WordPress.org requirements page “…WordPress also works with PHP 5.2.4+ and MySQL 5.0+ …” With Jetpack having 4+ million active installs backwards compatibility would be best. WP Tavern says “PHP 5.6 Is Now the Most Widely Used PHP Version.”
    Thanks

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Jetpack 5.2.1 + WP 4.8.1 is incompatible with PHP 5.3.28’ is closed to new replies.