Support » Plugin: Jetpack by WordPress.com » [Jetpack 4.3] Error: Cookie nonce is invalid

  • Resolved KemikalElite

    (@kemikalelite)


    Hi,

    I’ve updated to Jetpack 4.3 and it shows the error message:

    “Recommended features failed to activate. Error: Cookie nonce is invalid”

    when I try to enable any jetpack features.

    I’ve tried the following troubleshooting steps:

    -Logging out and in again.
    -Clearing all my sites’ cookies and wordpress cookies as well.
    -Different browser with clean user profile, both Chrome and Firefox.
    -Disabling WP-Super-Cache
    -Disabling CloudFlare
    -Reinstalling Jetpack

    Is this possibly a bug with the new 4.3 update? Jetpack works fine under 4.2.2.
    What normally causes this error?

Viewing 15 replies - 16 through 30 (of 35 total)
  • I installed W3 total cache and I get the same error. Now we know where this is coming from πŸ™‚ Caching plugins.
    @jeherve I hope this helps

    Yep. That’s it!

    Jetpack started working again immediately after deleting the rules from htaccess and disabling the cache plugin.

    Thank you @kingmanu.

    You welcome buddy, @kemikalelite
    But still we need a fix for this. I don’t want to work without a caching plugin πŸ˜€
    I will submit it as a bug report and Jetpack will fix that

    edit: I can’t do that because “our support form is closed for all users without a Jetpack plan until Friday, September 23rd.”
    Maybe @jeherve will help us.

    • This reply was modified 3 years, 11 months ago by Cornel Manu.

    I don’t have any caching plugin, but I use CloudFlare with Full SSL setup, and I have the same error, even if I put CloudFlare on development mode. Setting site address to https doesn’t help.

    Found it, I could activate Jetpack plugins after disabling the SuperSonic plugin:
    https://wordpress.org/plugins/supersonic/

    Probably the reason was that SuperSonic modifies URLs on the fly by adding ?supersonic=wp-admin to them.

    @cezariuszmarek Don’t you think it’s possible SuperSonic adds caching rules to the htaccess file? It all seems connected with that.

    I communicate with the jetpack team on email and try to figure out a solution for this. They don’t seem to be able to replicate the error. I will keep you guys updated if something changes.

    Don’t you think it’s possible SuperSonic adds caching rules to the htaccess file?

    @kingmanu No, it doesn’t. It works very differently from other cache plugins.

    Update: W3 Total Cache just released a new version, and the error doesn’t appear anymore with the updated version of the caching plugin. I can deactivate and activate jetpack functions.

    https://wordpress.org/plugins/w3-total-cache/changelog/

    For WP Super Cache you need to deactivate this setting:

    As Brandon, from Jetpack staff, said:

    With this option set (to make known issues anonymous), WP Super Cache removes the auth from the cookie, which then Jetpack tries to use to activate a module. Since the cookie appears to be from an unauthenticated user, it fails.

    I hope this helps users until Jetpack will make an update to remove this error. It has been submitted for fix.

    I simply deactivated the plugin and again I re-connected with wordpress.com
    This problem was solved.

    I’m having this problem with the Video Press Switch. I don’t have any of the caching plug-ins, and it seems that there may be another fix.

    I am using SiteGround’s SG CachePress which is described as “Through the settings of this plugin you can manage how your WordPress interracts with NGINX and Memcached.”

    I deactivated the SG CachePress plugin and was then able to set Jetpack parms, then I re-enabled the SG CachePress plugin with no problem. Then I was able to change Jetpack parms, again with no problem.

    From reading all the posts I am highly suspicious of caching. Even without a caching plugin it may be the case where the host is using caching of some sort (I’d be surprised if they weren’t) and that is causing the problem. It may be as simple as clearing browser cache but I doubt it.

    Hope this helps.

    Jerry

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic πŸš€

    Caching can indeed interfere. For those of you not using a caching plugin, could you try to log out of your WordPress account, and then log back in and try again?

    If that doesn’t help, could you try in a different browser?

    If you still experience issues, could you try the following:

    1. Open the dashboard page.
    2. Open your browser console
    3. Click on the Network tab
    4. Refresh the page.
    5. Try to trigger the error again by activating a module or changing options.
    6. If you see any lines in red inside the browser console, click on them. A new panel should appear on the right.
    7. Click on the “Response” tab in that new panel.
    8. Copy the message displayed there.
    9. Paste it here.
    10. If no red lines appeared in the browser console, click on the “Console” tab of the browser console.
    11. Copy any errors displayed there, and paste them here.

    Thanks!

    That didn’t work for me. I don’t use WP Super Cache.

    WHat’s causing this?

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic πŸš€

    @morespinach Could you please start your own thread, as per the Forum Welcome?
    https://wordpress.org/support/plugin/jetpack#new-post

    it would be useful if you could post the results of the tests I mentioned above, as well as post a list of the other plugins you currently use on that site.

    Thank you!

Viewing 15 replies - 16 through 30 (of 35 total)
  • The topic ‘[Jetpack 4.3] Error: Cookie nonce is invalid’ is closed to new replies.