Support » Plugin: Jetpack by WordPress.com » jetpack 4.3 dashboard gives php warnings, broken?

  • Now that 4.3 is installed, when I go to the new jetpack dashboard, I get this message repeated three times:

    Warning: Cannot modify header information - headers already sent by (output started at [fileroot]/SITENAME/wp-includes/script-loader.php:1304) in [fileroot]/SITENAME/wp-includes/rest-api.php on line 359

    path name sanitized to protect the innocent

    I’ve emptied caches, but the warning persists on viewing the jetpack dashboard. PHP 7.10, wp-rocket, and cloudflare, over https as well.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Sadly, I get the same Warnings at another site 🙁
    They get injected like five lines in the admin area

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic

    Thank you both for the reports!

    Do you happen to use other plugins relying on the core REST API on your sites? If so, could you try to deactivate those plugins, and let me know if the error disappears at some point?

    If that doesn’t help, or if you don’t use such a plugin, could you add the following to your site’s wp-config.php file?

    
    define('WP_DEBUG', true);
    
    if ( WP_DEBUG ) {
    
            @error_reporting( E_ALL );
            @ini_set( 'log_errors', true );
            @ini_set( 'log_errors_max_len', '0' );
    
            define( 'WP_DEBUG_LOG', true );
            define('WP_DEBUG_DISPLAY', false);
            define( 'CONCATENATE_SCRIPTS', false );
            define( 'SAVEQUERIES', true );
    
    }
    

    Once you’ve done so, try reproducing the error, and then check the wp-content/debug.log file for errors. You can paste the results here. You can then replace define('WP_DEBUG', true); by define('WP_DEBUG', false); in the code above.

    Thanks!

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.