WordPress.org

Support

Support » Plugins and Hacks » [Resolved] JetPack 2.2.2 not passing new posts to facebook

[Resolved] JetPack 2.2.2 not passing new posts to facebook

  • gazouteast
    Member

    @gazouteast

    Following a catastrophic failure when migrating the site (www.freechoicegames.com) to a new host (a VPS) I started with a completely fresh clean WP 3.5.1 and changed to a new theme (SilverOrchid)

    Plugins installed so far –
    Akismet
    JetPack
    WordFence Security
    AdRotate
    Extended AdRotate Ad Placements
    Zamango Money Extractor

    All plugins are the latest repository version, except Zamango which is the latest from their site.

    I activated Publicize with a facebook and twitter account – the twitter account works fine, the facebook connection does not work at all. I’ve tried the disconnect and reconnect as per regularly posted instructions by Jeremy. The debug at the bottom of JetPack shows site and user tokens set up and verified. Facebook shows wordpress.com is connected in the apps list.

    My only thought is that because Zamango auto posts all posts via a feed, this is not being seen by Publicize as new posts and therefore not pushed to facebook, but if that is the case, then why is twitter receiving them?

    I’ve enabled the facebook community widget, which is pulling from facebook happily (see footer zone of site) but jetpack is not pushing to facebook.

    I’m pretty much stumped now – WordBooker was handling posts up to facebook before the server migration, but like others I’m trying to reduce maintenance by using the jetpack to cut down on updates and plugins.

    Any clues anyone?

    http://wordpress.org/extend/plugins/jetpack/

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Contributor Richard Archambault
    Happiness Engineer

    @richardmtl

    Hi!

    I would guess that this is a conflict with Zamando, but I’d like to check things out. Can I have a link to your site, please?

    gazouteast
    Member

    @gazouteast

    Hi Richard – it’s in the first line of the OP

    Gaz

    Jan Dembowski
    Volunteer Mod. & Brute Squad

    @jdembowski

    It’s not converted to a link but it’s this site.

    Plugin Contributor Richard Archambault
    Happiness Engineer

    @richardmtl

    Hi, sorry I missed the URL in your OP.

    So I had a look at Zamanga and I don’t see why it’d have an issue with Publicize, the code looks like it should work. However, I noticed that you mentioned that you have Wordfence installed. This plugin usually blocks access to the xmlrpc.php file, which is required for Jetpack. Can you try deactivating it and see if that solves the issue?

    gazouteast
    Member

    @gazouteast

    Hi Richard – tried it with WordFence de-activated and Zamango still didn’t post to facebook.

    Checking the facebook page (facebook.com/freechoicegames) I remembered that a directly typed post did go to facebook a few days ago.

    Perhaps there’s something in Publicize blocking posts from feeds, and only allowing direct entries through?

    On the site at work (which I manage) we have wordfence and jetpack, and there’s never a problem with Publicize – all manually-entered posts are on facebook and twitter within seconds.

    gazouteast
    Member

    @gazouteast

    Just a random thought – is it possible to build a delay into Publicize (an itchy finger mode) to delay passing the post to facebook for say 60-120 seconds after the publish action of the post?

    That way, posts introduced from feeds would have the chance to save in the database and show on site before Publicize triggered the upload to facebook.

    Plugin Contributor Richard Archambault
    Happiness Engineer

    @richardmtl

    Hello again!

    So after taking a closer look at Zamanga, I think I found the reason:

    if (!defined('WP_IMPORTING'))
                    define('WP_IMPORTING', true);

    On line 148 of zmg_money_extractor.php

    With that variable set as TRUE, Publicize won’t push a post to Facebook. I do not know why the plugin is setting that variable; I’d suggest asking the authors or removing that line to see if there are any problems with removing it.

    Let me know how that goes!

    gazouteast
    Member

    @gazouteast

    Ah-ha … interesting

    Had another wild thought and looked in the database to see if there was anything odd in there.

    Noticed the guid column was strange –
    Zamango posts are saving a guid such as “http://trivia-machine-reloaded”
    whereas direct-typed posts are saving the guid as “http://www.freechoicegames.com/?p=1”

    The permalinks option is set as “http://www.freechoicegames.com/2013/04/sample-post/” – I re-saved that to see if it makes a difference.

    edit to remove some nonsense here

    Checking the main php file of the plugin, they use the guid column to set an index for each post, so they can check if the post content has been updated since the last fetch for that post.

    Even more stumped now.

    gazouteast
    Member

    @gazouteast

    OK Richard – just seen your reply above at post #8

    I’ll ping the developers on this now – probably take them 24 hours or so to get back to me.

    Thanks

    gazouteast
    Member

    @gazouteast

    Richard

    I think I know why that WP_IMPORTING setting is there – it’s to prevent database bloat explosions.

    The Zamango feed updates around 20 posts per day after importing the (currently) approx 3600 posts in the game feed. Over the course of just one year that would auto-generate 7500-ish post revisions (365×20) on top of the actual posts. Any manual re-imports would also create 3600 revisions each time.

    If I’m correct and based on your comment about it then it would seem that posts from feeds, when revisions are turned off to prevent database bloat, cannot be posted to facebook?

    Does the same restriction apply if
    [code] define (‘WP_POST_REVISIONS’, 0); [/code]
    is used in wp_config.php ?

    gazouteast
    Member

    @gazouteast

    Richard – many thanks for the spotting of that WP_IMPORTING line.

    I’ve now disabled that and set revisions=0 in the wp-config.php and it all works fine now. I waited a while before posting this to make sure no side issues kicked up.

    Problem solved 🙂

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Resolved] JetPack 2.2.2 not passing new posts to facebook’ is closed to new replies.