WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Jetpack 2.1.2 breaks my theme

[Resolved] Jetpack 2.1.2 breaks my theme

  • copperbeech
    Member

    @copperbeech

    I’m having a problem with Jetpack interfering with my theme. I use the Chameleon theme by Elegant Themes. The theme works fine when Jetpack 2.1.2 is activated. However, when I connect it to WP, the slider on my theme doesn’t load its images. Elegant says it’s a plug-in problem and won’t touch it. Any suggestions? I really value the information the Jetpack stats provide, as well as the sleek widgets, though I’m not interested in it breaking other functions on my site.
    Thanks.

    http://wordpress.org/extend/plugins/jetpack/

Viewing 15 replies - 1 through 15 (of 22 total)
  • Alison Gillespie
    Member

    @alison-gillespie

    I’m having some problems that are similar. I also use Elegant Themes… but PureType. Once I updated to Jetpack 2.1.2 the images all were blocked from view. Without Jetpack the whole site is fine. Once Jetpack is activated it is a mess for all images.

    Any info you can offer is appreciated. Would like to reactivate the Jetpack and start getting stats again, as well as use the widgets.

    jmkantrow
    Member

    @jmkantrow

    I have a similar problem. I’m using the Duplex theme and when I activate Jetpack 2.1.2, the slider feature stops working. I rely on Jetpack for daily stats, but this conflict is quite a problem because it affects the functionality of my website. I have deactivated Jetpack, hoping another update will come up soon to solve this problem. My website is http://www.newsismybusiness.com.

    Any idea, if a Jetpack update is in the works?

    Plugin Author Jeremy Herve
    Participant

    @jeherve

    Could you all post your site URL here, so I can have a look?

    If you want it to remain private, you can also contact us via this contact form:
    http://en.support.wordpress.com/contact/?jetpack=needs-service

    Could you also give me more information about the Sliders you use? Are these added by a specific plugin, or are they part of the theme?

    Could you also try to deactivate all Jetpack modules, one at a time, in order to check if one of them conflicts with your slider?
    You might want to start with the Photon module, since it affects all images on your site.

    jmkantrow
    Member

    @jmkantrow

    Hi…all of the info you requested is in my previous entry. In the meantime, I’ll go ahead and follow your suggestion about deactivating Jetpack modules.

    Thanks!

    copperbeech
    Member

    @copperbeech

    http://www.kelleyharrell.com

    I have deactivated the Jetpack plug-in, however.
    Thanks for responding.

    Plugin Author Jeremy Herve
    Participant

    @jeherve

    @copperbeech Could you activate Jetpack, but deactivate the Photon module, and let me know if this helps?

    Could you also let me know if the images in your posts are also broken, or if the problem only appears with the Slider?

    copperbeech
    Member

    @copperbeech

    Thank you for being so responsive, Jeremy. I activated Jetpack and connected it to WP. I don’t have the option to either activate, configure, or deactivate the Photon module. Only “Learn More” shows.

    With Jetpack active and connected, only the slider images don’t work. Images in posts and pages seem to be loading as expected.

    Bestselling Author,

    Plugin Author Jeremy Herve
    Participant

    @jeherve

    @copperbeech Here is a quick video to show you how to deactivate Photon:
    http://i.wpne.ws/Mr5m/content

    copperbeech
    Member

    @copperbeech

    LOLOLOLOL. Done!

    Plugin Author Jeremy Herve
    Participant

    @jeherve

    Thanks. Since your Slider seems to work now that Photon is disabled, the problem seems to be linked to your theme, and to the way the pictures are called in the Slider.

    Unfortunately, I cannot investigate further without seeing the theme’s code, but you could send this link to the theme author and let them know about the issue; they might be able to investigate further on their end:
    http://jetpack.me/support/photon/

    jmkantrow
    Member

    @jmkantrow

    My Theme just plain stops working properly as soon as Jetpack is activated and connected to WordPress. The slider stops working. I opted to take it down until a fix is found, however that’s a problem for me because I like to be able to see the traffic there rather than have to go to Google Analytics.

    I hope the problem is resolved soon.

    Plugin Author Jeremy Herve
    Participant

    @jeherve

    @jmkantrow Have you tried disabling the Photon module, as I suggested above?

    Do you experience issues with images outside of the Slider?

    jmkantrow
    Member

    @jmkantrow

    Hi. I don’t have a choice in disabling the photon module. And yes, if the photo isn’t visible in the slider, it’s not visible in the story (post), but that only happens with Safari. Other browsers are ok, as far as I know.

    Thanks for your quick response!

    copperbeech
    Member

    @copperbeech

    Thanks for your quick response and assessment. I’m curious to see if Elegant will respond to this issue, since it is across various of their themes. I directed them to the link you cited, and this thread.

    Cheers!

    Plugin Author Jeremy Herve
    Participant

    @jeherve

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘[Resolved] Jetpack 2.1.2 breaks my theme’ is closed to new replies.