WordPress.org

Support

Support » Plugins and Hacks » Jetpack by WordPress.com » [Resolved] Jetpack 2.0.4 Breaks NextGen Galleries

[Resolved] Jetpack 2.0.4 Breaks NextGen Galleries

  • After upgrading to 2.0.4, my nextgen galleries do not work. Just a blank page. If I de-activate Jetpack, the galleries work fine. If I uninstall and reinstall jetpack 2.0.4, all is well UNTIL I reconnect the Jetpack to wordpress. Only after I connect/authenticate to wordpress do the nextgen galleries once again break.

    I am using nextgen 1.9.8.

    http://wordpress.org/extend/plugins/jetpack/

Viewing 15 replies - 16 through 30 (of 57 total)
  • Would one of you be willing to email us directly [here] with URL to your site w/ login information? We’d like to take a closer look at this error and see if there is anything we could do to help prevent this from occurring.

    Thanks!

    It may be related directly related to JetPack. Are you sure it’s NextGen ?

    Same issue on my site but the fix Timperator posted (many thanks) resolved it.

    @photocrati

    There is an hint from robf in this thread (problem might be caused by sharing service enabled), I didn’t test it, but he might be right.
    In sharing-service.php (jetpack) there is an filter added (linked to function sharing_display in the same file). With my fix this filter is also disabled.

    I can give access to my development environment, but need some time to make it visible from outside…let me know if you are interested.

    @timperator, We’d be very appreciative of that. If you could provide those details by submitting a bug report that would be great! Thanks!

    Add me to this list. Just wasted an hour wondering why when selecting a Gallery from a Nextgen ‘Album’, I get a blank page. Linking directly to galleries seems to be ok. For me, the problem only occurs when when linking to a gallery from within an album.

    Follow-up… After deactivating Jetpack 2.04, everything works great (except the various Jetpack contact forms I used). Going to confirm downgrade to 2.02 (per paulhlee) get’s back up and going again.

    @photocrati

    Unfortunately I do not have a development setup I can test with, and I’ve downgraded my Jetpack to 2.0.2 so that my live site works, so I have no way to really troubleshoot at this point.

    Wait, I thought the problem with NextGen and version 2.04 was solved ? Now the suggestion is to downgrade back to 2.02.

    @timperator you are the man.

    Our Feed Them Social plugin was having issues were the feeds were appearing at the top of the page, and this resolved it. Just going to have to include this fix on our readme file until jetpack decides to fix it.

    Shameless I know but….
    Check out our plugin for all you Facebook Group, Instagram or Twitter lovers.
    http://wordpress.org/extend/plugins/feed-them-social/

    @xfactory:
    There are multiple ways to fix this problem:
    – downgrade Jetpack to 2.02
    – disable Jetpack / remove link to wordpress.com
    – Apply my fix

    choose the one you like 🙂

    @photocrat

    I can give you access to my site if wanted just let me know and i will set you up aceess

    @timperator

    Thank you!!! Your fix worked for me 🙂

    Thanks to all of you for answering my question before I could even ask!

    @slickremix: The bug is actually in your plugin. You’re doing shortcodes wrong. Shortcodes, like filters, must return the content to be inserted into the post, not output it.

    NextGen Gallery has the same basic bug, but at a much deeper level. It’s had this bug for years, and they’ve never fixed it.

Viewing 15 replies - 16 through 30 (of 57 total)
  • The topic ‘[Resolved] Jetpack 2.0.4 Breaks NextGen Galleries’ is closed to new replies.
Skip to toolbar