WordPress.org

Forums

[resolved] Javascript troubles inside posts... (5 posts)

  1. ju1ie
    Member
    Posted 8 years ago #

    I am having problems with a certain javascript script. I pretty much explained everything over here: http://w3schools.invisionzone.com/index.php?showtopic=5599

    I am using wordpress 2.03 and my theme is "sunset 1.01" or "sunset". I hope someone can help. I have also searched the forum and didn't find anything to fix my problem.

  2. You can't put javascripts inside posts, by default.

    Try my little plugin: http://ottodestruct.com/wpstuff/scriptenabler.zip

    It will let your scripts inside the posts work. You may have to edit and save the post again after activating the plugin.

    Also, you will need to disable the rich editor by going to the bottom of your Users page, so that the editor itself doesn't hork up your script.

  3. ju1ie
    Member
    Posted 8 years ago #

    Thanks for the fast reply! Thanks for the plugin too. I will let ya know if it works or not. :) Thanks, again! :)

    PS. I installed the plugin but the javascripts don't seem to be working inside the pages. I have the rich text thingy disabled.

  4. The plugin is not perfect. Remove any extraneous blank lines, for starters. I need to work on this plugin a bit more to get all cases.

  5. wifiman01
    Member
    Posted 8 years ago #

    Dear Otto42,

    I have try your plug in doing like you said but the Javascript (a kelkoo banner) does 't appear on the post as well. Any other idea ?

Topic Closed

This topic has been closed to new replies.

About this Topic