Support » Plugin: Fast Velocity Minify » Javascript Options when Minification Interferes w/ Site Menu

  • Resolved darrenchu


    First off, thank you for creating an amazing plugin. It really helps boost my website load speed.

    One thing I noticed today though is that with my mobile display of my website, the menu (in the upper left hand corner of the website) no longer responds when clicking on it. I went into the Javascript settings within the plugin, and disabled the minification of Javascript, and cleared my cached files, but to no avail.

    The menu is provided by my website’s theme…any other plugin configuration options you’d suggest I tweak? I tried disabling the plugin altogether but that didn’t help either.

    Much appreciated in advance!

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Raul P.


    I’m sorry, but if the menu doesn’t work even if you disabled the plugin, that means the theme or some other plugin is causing the issue. FVM only merges the files, it cannot fix what is already not working.

    Did you update some other plugin or your theme perhaps?
    Or maybe, your cache is not clearing properly either at the server level?

    Do you see any reference to the cache/fvm directory on the frontend source code (view source on google chrome), when you disable the plugin?
    Does the menu work when you have the fix page editors option enabled and you are logged in?
    Are you purging all caches, including any cache of your hosting provider?

    Hi Raul,
    Tks for the quick response!

    I’m not sure how to clear the cache at my Linux server level. I use Godaddy and have a Virtual Private Server which I access normally via Cpanel. I’ll look further into this.

    In the meantime, I’ve deactivated both Fast Velocity as well as Hummingbird, and have cleared cache w/ both my mobile Chrome and Firefox. Chrome and IE on my desktop interestingly don’t present the same menu issue, so you’re right, this appears to be an issue potentially w/ my theme. I’ve written to my theme developer and will update once I hear back from him.

    Tks again,



    hello there.
    firstly thanks for the great plugin. it dramatically improves test scores.
    i tried a number of plugins but i could say yours could be the best.
    i have only one and the same problem with @darrenchu .
    my mobile menu doesnt work.
    i use storefront child theme galleria.
    i tried the same with darren plus i tried to exclude navigation.js asset of the storefront which didnt work.
    i saw default ignore list and there are a few pre defined themes, plugins etc.
    maybe you have the answer @alignak :))

    • This reply was modified 1 year ago by mybunnyb.
    Plugin Author Raul P.


    @mybunnyb the answer is the same as usual as stated on the faqs. You need to try different files which my be unrelated to the one not working, until you find it.

    If you see the console log on chrome, it gives you hints:

    If you look at the status page for the log, it shows you a list of merged files (or you could just append .txt to the js file name).

    Then the error comes from (screenshot, line 407):

    Note that by default, you should not have so many files enqueued from /wp-includes/js/dist/ so something could be wrong with some other plugin.

    For example, similar situations:

    FVM will simply merge what’s enqueued, but you should check if those other files really need to be enqueued or if some other plugin is enqueueing everything, without actually being needed.

    Finally, note that even if you add that file to the ignore list, there may be others as well. You need to track them down or hire a developer to find out where is the conflict.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Javascript Options when Minification Interferes w/ Site Menu’ is closed to new replies.