Javascript not working after domain name changed (3 posts)

  1. cawanpink
    Posted 7 years ago #

    i have just moved a copy of wordpress from my local machine to a server. it is exactly the same copy (files & database). the problem is the js doesnt seem to work in admin panel for wordpress copy at the server (eg i cant drag and drop in Widgets, clicking Quick Edit will result in nothing, i cant upload media using the buttons on the textarea). local's copy working fine.

    [1] i have updated the 'siteurl' and 'home' at the server to reflect the new url
    [2] i have checked all the file permissions (644) & folders' (755) except the 'uploads' folder - wordpress has write access to it
    [3] also i've done this:

    UPDATE wp_posts SET guid = REPLACE (guid,

    can anyone please tell me - what is wrong? what did i miss?

    thx much

  2. richarduk
    Posted 7 years ago #

    Dumb and obvious reply - have you checked you have no applications that see JS online as a threat and thus disable JS? Norton, or something.

    Are there any error messages in your browser?

    have you tried different browsers?

    Does JS work elsewhere online?

  3. cawanpink
    Posted 7 years ago #

    yes i've tried different browsers. on IE there's an error, something like

    Line: 13
    Char: 293
    Error: Invalid character
    Code: 0
    URL: http://mygosscon.oscc.org.my/2009/wp-admin/index.php

    when i viewed source line 13 is this:
    <link rel='stylesheet' href='http://mygosscon.oscc.org.my/2009/wp-admin/load-styles.php?c=1&dir=ltr&load=dashboard,plugin-install,global,wp-admin&ver=278e896882ccaccb587de3e5e99b9e6e' type='text/css' media='all' />

    i can open both local's and server's copy side by side and the local one will always work. i'm sure js works because i hv multiple wordpress sites that i can view and they work as expected. i dont have norton or anything like that running.


Topic Closed

This topic has been closed to new replies.

About this Topic