Support » Plugin: upPrev » Javascript not loading?

  • Resolved adamdport

    (@adamdport)


    The plugin’s not working for me. Scrolling down the page does nothing. The #upprev_box div is being generated and the stylesheet is being loaded. If I manually remove the “display:none” property of the div, I can see the div. However, both Chrome and Firefox indicate that upprev.js is not in my list of sources.

    Upon further inspection, the problem is that in my custom theme, I deregistered the wordpress default ‘jquery’ handle to use the copy hosted by google (performance tweak). This plugin hardcodes “jquery” as a wp_enqueue_script dependency. Changing it to “custom-jquery” to match my handle fixed it.

    Marcin, consider adding an “advanced option” to either set this dependency manually, or ignore it altogether.

    http://wordpress.org/extend/plugins/upprev/

Viewing 1 replies (of 1 total)
  • Plugin Author Marcin Pietrzak

    (@iworks)

    Upon further inspection, the problem is that in my custom theme, I deregistered the wordpress default ‘jquery’ handle to use the copy hosted by google (performance tweak). This plugin hardcodes “jquery” as a wp_enqueue_script dependency. Changing it to “custom-jquery” to match my handle fixed it.

    Use deregister/register as ‘jquery’ not ‘custom-jquery’.

    wp_deregister_script( 'jquery' );
    wp_register_script( 'jquery', 'http://ajax.googleapis.com/ajax/libs/jquery/1.7.2/jquery.min.js' );

    upprev.js – give me a website url.

Viewing 1 replies (of 1 total)
  • The topic ‘Javascript not loading?’ is closed to new replies.