WordPress.org

Support

Support » Themes and Templates » [Resolved] javascript exception on 'new wp.Uploader' when customizing this theme on 3.8.1

[Resolved] javascript exception on 'new wp.Uploader' when customizing this theme on 3.8.1

  • When using your (excellent) theme, if I click on Appearance | Themes |Customize I get this Javascript exception (below) which prevents that UI from working.

    My site is http://www.ibeck.com and I’m an ROR developer so I love Bootstrap, naturally.

    The exception doesn’t happen with any of the default themes so I’m suspecting an integration issue.

    But, what’s odd is that I don’t get the error running locally on Mac OSX with PHP 5.4.17, but I do get it running on my Linux Box with PHP 5.3.16. I’m using identical databases and code. Alas, no clues in the PHP log.

    TypeError: 'undefined' is not a constructor (evaluating 'new wp.Uploader(this.uploader)')
    readyload-scripts.php:2:2580
    readyload-scripts.php:2:3355
    (anonymous function)load-scripts.php:2:821
    nload-scripts.php:2:29308
    fireWithload-scripts.php:2:30073
    (anonymous function)load-scripts.php:1:7570
    nload-scripts.php:2:29308
    addload-scripts.php:2:29519
    whenload-scripts.php:1:3831
    instanceload-scripts.php:1:2879
    fload-scripts.php:1:649
    initializeload-scripts.php:2:668
    Classload-scripts.php:1:700
    (anonymous function)load-scripts.php:1:299
    (anonymous function)load-scripts.php:1:299
    (anonymous function)load-scripts.php:1:299
    (anonymous function)load-scripts.php:2:20526
    eachload-scripts.php:2:18119
    (anonymous function)load-scripts.php:2:10867
    nload-scripts.php:2:29308
    fireWithload-scripts.php:2:30073
    readyload-scripts.php:2:16008
    Bload-scripts.php:2:20580
    Main Frame

    The Bootstrap

Viewing 4 replies - 1 through 4 (of 4 total)
  • The exception doesn’t happen with any of the default themes so I’m suspecting an integration issue.

    Does it happen with any other theme? Any other bootstrap based theme?

    But, what’s odd is that I don’t get the error running locally on Mac OSX with PHP 5.4.17, but I do get it running on my Linux Box with PHP 5.3.16. I’m using identical databases and code. Alas, no clues in the PHP log.

    Yes, I couldn’t reproduce it on my sandbox either. I strongly doubt it’s the theme, I’d rather look at the uploader.

    Thanks for the quick reply, Konstantin. I’ll have to try another theme and see if I can reproduce on my server. It was worth asking to see if you’d heard of anything similar.

    The troubling part is that it doesn’t happen locally so it could be an environmental (e.g., rights) issue on my server. Maybe there is some script I can run that repairs the rights on my server?

    FWIW, I install everything manually. Here is my procedure.

    1. Download ZIP file to Mac
    2. Unzip ZIP on Mac
    3. Tar on Mac
    4. SCP to Server in themes folder
    5. Un-Tar on Server
    6. Activate

    Alas, my server doesn’t have an unzip program.

    Do you know if any of the theme folder content needs to be apache writeable?

    I’m a wanker. This solved the issue

    cd themes/the-bootstrap
    chmod -R 755 *.php

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] javascript exception on 'new wp.Uploader' when customizing this theme on 3.8.1’ is closed to new replies.