Support » Fixing WordPress » Javascript errors on clean install

Viewing 6 replies - 1 through 6 (of 6 total)
  • Mark (podz)

    (@podz)

    Support Maven

    I see those errors on a 2.0.1 blog if I have the js checker going.

    If posting is slow and you have pingomatic in the Update Services box, remove it. That should help.

    Thanks, podz. That does seem to speed things up significantly.

    I have the same problem – it’s preventing the RTE from showing up. I’m running 2.0.2. Errors are pretty much identical. I’m running Firefox 1.5, but the errors show up in IE as well.

    Is there a fix?

    Happyworker

    (@happyworker)

    I’m getting similar errors…

    Error: Unknown property ‘zoom’. Declaration dropped.
    Source File: http://www.jgsprintmedia.com/blog/wp-admin/wp-admin.css?version=2.0.3
    Line: 605

    Error: Unknown property ‘-khtml-opacity’. Declaration dropped.
    Source File: http://www.jgsprintmedia.com/blog/wp-admin/wp-admin.css?version=2.0.3
    Line: 922

    Error: Unknown property ‘filter’. Declaration dropped.
    Source File: http://www.jgsprintmedia.com/blog/wp-admin/wp-admin.css?version=2.0.3
    Line: 923

    Error: Selector expected. Ruleset ignored due to bad selector.
    Source File: http://www.jgsprintmedia.com/blog/wp-admin/
    Line: 48

    Error: Unexpected end of file while searching for closing } of invalid rule set.
    Source File: http://www.jgsprintmedia.com/blog/wp-admin/
    Line: 49

    I’m not sure but I think this happened when I got the idea to have a spell checker. Go figure, a spell checker for blogging? Well I downloaded and installed a plugin called Editormonkey. I had a hard time getting this plugin to work, and eventually wanted to uninstall it, this is when the problems really started.
    My buttons got all screwed up…..so I found some support in WordPress and found I wasn’t the only one. I ended up taking all instances of editormonkey out of mysql, and getting my buttons to return, but now I have a whole new set of problems *see above.

    I’m also having problems with FF. FF doesn’t want to play nice when I go to edit a post or write one. I tried taking off the Rich Text Editor, but it keeps showing up. I also try changing text within my post, but it doesn’t work….just goes back to the way it was. I also try opening up my post using the HTML button on the Rich Text Editor, but the pop up comes up blank. Arg….
    I can however change all of this through IE, but I don’t always like using IE.

    Quite the domino effect I’m having. When is WordPress 2.1 coming out, so I can upgrade this mess and have a spell checker??

    Has anyone else run into these problems, and if so….have you fixed it?

    Has anyone fixed this problem. I installed WP 2 a couple of days ago. the wysiwyg editor was working fine and then just dissapeared after 3 and one page. there’s a complete tinymce folder in the js folder, but not sure how to get it called into action again.

    thanks

    I “solved” the problem by attempting to follow the advice here: http://trac.wordpress.org/ticket/3572

    In the tiny_mce_gzip.php file (in the tinymce folder), I commented out the following lines (starting around 137):

    if ((in_array(‘gzip’, $encodings) || in_array(‘x-gzip’, $encodings) || isset($_SERVER[‘—————‘])) && function_exists(‘ob_gzhandler’) && !ini_get(‘zlib.output_compression’)) {
    $enc = in_array(‘x-gzip’, $encodings) ? “x-gzip” : “gzip”;

    // Use cached file if it exists but not in debug mode
    if (file_exists($cacheFile) && !$debug) {
    header(“Content-Encoding: ” . $enc);
    echo file_get_contents($cacheFile);
    die;
    }

    if (!$diskCache)
    ob_start(“ob_gzhandler”);
    } else
    $diskCache = false;

    Who knows, this might break something else, but at least the editor is back for now. :-/

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Javascript errors on clean install’ is closed to new replies.