Support » Fixing WordPress » Javascript errors (multiple)

  • For some strange reason, I can not get any javascript to run without errors. I’m using WordPress 2.0.4 and Podpress 6.8. At first, I thought it was a problem with PodPress because the media player (a javascript player) was not working and coming back with an error.

    I disabled and unistalled PodPress, and then noticed that all of the javascripts in the Admin pages were also coming back with errors.

    Furthermore, I can not get ANY Google AdSense (another javascript) to run on any page, or any post. I’ve created a test page in plain .htm and the javascript works fine. Also can’t get an IFRAME to work in the blog, but works fine in an .htm page.

    So I’ve concluded that it MUST be a problem with WordPress, or the installation. Perhaps I may have installed incorrectly? Hey, it’s possible.

    I’ve searched this site for any clues… none! So, can someone please help?

    There are several people using PodPress with the same problem… who are also using WordPress. I think the problem must be with WordPress.

Viewing 11 replies - 1 through 11 (of 11 total)
  • I won’t answer the iframe question, since I don’t know anything about frames (except that I hate them on a website)

    There might be something wrong with your install, your server, your browser… I installed several times the Podpress thing for clients and it has never had any JS errors.

    FF doesn’t detect JS error even on your site… however, I did detect more than 150 validation errors, some of them related to how you use JS in your blog:

    Might help us help you if you told us what specifically you are doing to add in Javascripts and the like. making us guess is not the way to go.

    I appriciate your responses. Please visit for reference.

    Well, to start, I haven’t messed with any of the code for WordPress or PodPress. Just trying to use the programs. So I’ll have to look at these 150 validation errors… which I did not create. From the looks of it, this is code generated from the WYSIWYG editor in “Write Post”.

    To start… NONE of the google AdSense (javascript code) works in a post or a page. Specifically, if I go to AdSense, generate an AdSense code, copy it, and then paste it into a post or a page, etc… the ad does not show up on the page after saving. If I take the same code and create an .htm page, the Ad works. See

    I found a work around today by using the AdSense Deluxe Plugin. So if you look at my site now, you will see AdSense banners… but it’s not the way I want to use it or have seen in other blogs using WordPress.

    The other javascript error I have has to do with the PodPress media player (also javascript). The “Hide Player” link doesn’t work and returns an error. See screen shot at: Had major errors in both the blog and admin pages using PodPress 6.8… rolled it back today to version 6.7 and now only have a javascript error with the “Hide Player” link.

    I also have Fire Fox installed and although it does not show the error, as you mentioned, the link still doesn’t work. I’ve seen this all work just fine on other WordPress & PodPress blogs running the same versions as I am.

    Another note… I get the same errors on other machines and other IE browsers… so it’s can’t be my machine, OS, or IE install. Although, I’m open to the possibility that it ‘might’ be something on my machine… just have no idea what it could be.

    As for IFRAMES. I’m also a member of the Amazon Affiliate Program. All of their code is IFRAMES… which is VERY different than Frames. I hate frames as well, but IFRAMES is a bit different. It’s like a remote window within a page… has scroll bars, etc. Point is… the IFRAME code will not display in a post or a blog.

    I guess I’m mostly interested in trying to figure out how to get this Google AdSense javascript code to work in a post… AND… stay with the RSS2 feed so it also replicates with all the blogs my feed is syndicated with.

    Opps… the image link got the period in the hyperlink. Try this one:

    Also… There’s an error on this page too.

    Is it possible that the problem is with the theme? Which is generating almost all of the code that isn’t valid?

    Just trying to brainstorm some possibilities here.

    Well, for starters… you should never ever copy/paste a code into the wysiwyg animal 🙂

    Wysiwyg can screw up even a simple plain text, so what do you expect when it comes about code? It has been posted approx. 100 times: if you have to put your own code into a post/Page – disable that monster, please!!!

    With the wysiwyg disabled > you should read this:

    LOL Okay Moshu… I’m learning my lesson about WYSIWYG. 🙂

    I’ve been codeing in Frontpage (the editor, not the WYSIWYG), and then copying the code into the WordPress editor. Found the check box to turn it off in “My Account”. I’ll try and be more careful.

    I’ve been working on all these validation errors this afternoon. Some of them I’ve create accidentally by using the WYSIWYG editor AND by not keeping up with the XHTML 1.0 strict. So far, it’s mostly things like using “/>” to close a tag instead of just “>”.

    Some of the errors though, I didn’t create and are created by WordPress or PodPress… like error #1. I have no idea how to fix that without having to go into the template. I think it might be coming from my template (that I borrowed). I just need to keep going through them and learn and understand the code.

    Still doesn’t fix my errors… but getting there.

    I’ll have to study this template feature. New to me. I’ll read it over and post how it goes.

    I sure appriciate your advice. Got any more helpful tips?

    Hey Moshu…

    Well, I’ve got the validation errors down to 24. Basically, if I ditch the PodPress Plugin, my Podcast Pickle Player (very popular player), and the Feedburner Newsletter subscription form… I’d validate.

    I don’t get it. How can I control being valide if I include all these add-ons to my site? Which I can’t control the code of? Is being XHTML 1.0 Strict compliant THAT big of a deal? And will it allow my javascript errors to work?

    By the way… I still get those javascript errors…

    It doesn’t have to be strict. That was just an over-zelous theme author. Transitional is OK.

    For me, the validation in itself is not a big deal (though it’s nice). However, when something goes wrong, like display problems or anything that relates to the output… and you need troubleshooting, the only rational way is to eliminate the validation errors and see whether it works or not. If still not working – then you can focus on some special issues instead of going through hundreds of (maybe) unrelated) errors. Does it make sense?

    Sure does…

    I ran the test against Transitional and only have 14 errors. I think I can fix them, but it means altering someone elses code (mainly the pickle player styles) I’m going to go with that one. Main reason… The only way I can figure out how to make my page center in the Fire Fox browser is to use the <center> element, which passes in Transistional but fails in Strict.

    That to me is a big deal… I’d rather my site look as good as possible in as many browsers and platforms as possible, and I hate pages shoved over to the left.

    I appriciate our discussion and you are forcing me to learn more codeing again… but my Javascript issues still exist. 🙂

    I’m having the same problem with the PodPress plugin. I’ve used it a couple of times, the first time… I somehow fluked out and it worked fine. Plays like a dream.

    The second time, it hasn’t worked. The player does not even appear in the post and when I hover over the ‘Play Now’ or ‘Play in Popup’ links, I get a javascript:void(null); message in the bottom bar on my browser. When I actually click the link, I get the error Can't load wp-config.php (located in "/homepages/0/d164063511/htdocs/wp-content"). You must put this plugin in your plugins directory ("/wordpress/wp-content/plugins/").

    What does this mean? The plugin is installed in the correct directory and the only thing that these locations could be from, I think would be from the settings?

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Javascript errors (multiple)’ is closed to new replies.