Support » Plugin: Responsive Mortgage Calculator » Javascript errors in 2.3.4 break functionality in IE11

  • I noticed that the latest version of the plugin (2.3.4) is throwing a javascript error:
    “Object doesn’t support property or method ‘find'”

    I was able to get around this by adding a polyfill for find (https://developer.mozilla.org/en-US/docs/Web/JavaScript/Reference/Global_Objects/Array/find) but then it began throwing a similar error for parseInt.

    Reverting back to 2.3.0 got it working in IE 11 again.

    We all hate supporting older browsers but many financial institutions are stuck on older versions of IE (IE 11 in my client’s case) due to internal systems etc., so given the nature of this plugin, it would prob be a good idea to either mention IE compatibility on the plugin page or make note of it in the release notes when a breaking update is released.

    • This topic was modified 1 year, 7 months ago by tracyfloyd.
Viewing 4 replies - 1 through 4 (of 4 total)
Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Javascript errors in 2.3.4 break functionality in IE11’ is closed to new replies.