WordPress.org

Support

Support » Plugins and Hacks » JavaScript error and conflict with Front-end Editor

JavaScript error and conflict with Front-end Editor

  • Thanks for this awesome plugin.

    I have installed Front-end Editor plugin, and it was not working. I have followed the guide for javascript problems suggested on the FAQ section of that plugin, and I discovered that Contact Form 7 was the cause: Screenshot

    When I have deactivated the CF7 plugin, the error disappeared and Front-end Editor started to work. How can I fix this? Is this going to be fixed in future versions?

    Thanks!

    https://wordpress.org/plugins/contact-form-7/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Takayuki Miyoshi

    @takayukister

    Can I see your site?

    It is on production and not open to the public. I think this week will be online, and I’ll notify here 🙂

    @takayuki Miyoshi – I would very much like to get Front-end Editor working with my test site but although the ‘Edit’ button shows up, clicking it does nothing. Also, my slider images stop sliding with Front-end Editor installed. I have left it installed for the moment in case you want to look at the site.

    I’m using the Customizr theme which is very well supported.

    In case it matters, I am also using Contact Form 7 which is a long-established and well-supported plugin. I haven’t bothered to test without CF7 because it is now an essential part of my site – and if I have to deactivate it in order to be able to use Front-end Editor, then I might as well do my edits at the back end while I’m there.

    I love Front-end Editor (and Aloha Editor) and believe it will become a WP standard. So I will be sad if I can’t use it yet.

    Hi Takayuki.

    The site is live, but we are not using any of those 2 plugins ^^

    Thanks.

    same here. quite a fresh install. with both the “responsive” theme and twentyten as suggested here: http://wordpress.org/support/topic/front-end-editor-stopped-working-after-recent-upgrade

    I can confirm that the wysiwyg-enabled frontend editor does NOT work with Contact Form 7 activated (the non-wysiwyg works), and that it works once CF7 is deactivated. That applies not only to actual contact form pages, but to all pages (and probably posts).

    note that the site is not public yet.

    I have multiple sites that this is working just fine on, but one that it is not. Disabling cf7, enables FEE to work like a charm. Any chance there has been any progress?

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘JavaScript error and conflict with Front-end Editor’ is closed to new replies.