Support » Plugin: Paid Memberships Pro » Javascript Error!

  • Resolved BeeTeam368

    (@beeteam368)


    Hi Support Team!

    It caused an error with the content editor of Gutenberg:

    https://imgur.com/a/ngaAqH4

    block.js?30d7:32 Uncaught ReferenceError: pmpro is not defined
        at eval (block.js?30d7:32)
        at Object.<anonymous> (editor.blocks.js?ver=2.1.1:1)
        at e (editor.blocks.js?ver=2.1.1:1)
        at eval (blocks.js?3ef1:1)
        at Object.<anonymous> (editor.blocks.js?ver=2.1.1:1)
        at e (editor.blocks.js?ver=2.1.1:1)
        at editor.blocks.js?ver=2.1.1:1
        at editor.blocks.js?ver=2.1.1:1

    Thanks!

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Andrew Lima

    (@andrewza)

    Hi @beeteam368

    Thank you for using Paid Memberships Pro, I’m really sorry to hear about this issue you are facing.

    Is this error only happening for posts that have the ‘Require Membership’ block? Does this occur for other Paid Memberships Pro blocks?

    Thread Starter BeeTeam368

    (@beeteam368)

    Hi @andrewza ,

    I see that this error is reported from the WordPress webpark.

    (wp-content/plugins/paid-memberships-pro/js/editor.blocks.js)

    It seems that the packaging and minify of .js files has been problematic.

    It seems to be related to the code (js) you developed for Gutenberg.

    —-

    And I would like to confirm, this js bug does not damage Gutenberg. This is a problem with Chrome 77. And I just need to update to the latest version of Gutenberg to fix the problem ( https://wordpress.org/support/topic/wordpress-5-2-3-visual-editor-issue/ )

    —–

    Very sorry for bothering and wasting your time

    Best Regards!

    Plugin Author Andrew Lima

    (@andrewza)

    Thank you for the feedback and clarification. It’s no problem at all, it always helps to know about issues.

    Have a great day further.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Javascript Error!’ is closed to new replies.