Support » Everything else WordPress » java script not working in Subfolder in wordpress root, a .htaccess issue

  • Resolved yguvvala

    (@yguvvala)


    0
    down vote
    favorite
    I have wordpress installation on root folder. and i have tool with java script on a subfolder called smart inside the root folder.

    in my site http://www.jump2health.com/smart, the page doesn’t show up all the java script it is supposed to. where as i have uploaded it in a different place (http://billmath.com/smart/) and it works as expected. when i rename (remove) the .htaccess file which is in root the java script works as expected, however this stops my word press site from working normally.

    My htaccess file in wordpress installation is as follows:

    ## EXPIRES CACHING ##
    <IfModule mod_expires.c>
    ExpiresActive On
    ExpiresByType image/jpg "access 1 year"
    ExpiresByType image/jpeg "access 1 year"
    ExpiresByType image/gif "access 1 year"
    ExpiresByType image/png "access 1 year"
    ExpiresByType text/css "access 1 month"
    ExpiresByType application/pdf "access 1 month"
    ExpiresByType text/x-javascript "access 1 month"
    ExpiresByType application/x-shockwave-flash "access 1 month"
    ExpiresByType image/x-icon "access 1 year"
    ExpiresDefault "access 2 days"
    </IfModule>
    ## EXPIRES CACHING ##
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    I dont have any .htaccess file inside my subfolder.

    after extensive search tried every thing that I found on google search results with no success I tried adding a .htaccess file inside subfolder with:

    <IfModule mod_rewrite.c>
       RewriteEngine off
    </IfModule>
    That didn't help either

    I tried ignoring the folder from main htccess file in root which didn’t work.

    I tried many more please help me where is the catch

    I am new to wordpress

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • The topic ‘java script not working in Subfolder in wordpress root, a .htaccess issue’ is closed to new replies.