Support » Plugin: Autoptimize » Java optimisation exclusion

  • Resolved underro

    (@underro)


    I have a little issue.
    I try to use the reviews on other pages as well, using woocommerce blocks (the standard plugin from Automatic) but as long as java optimisation is enabled, it doesn’t display.

    I tried to make various exclusions, but I failed: all-reviews.js, plugins/woocommerce-gutenberg-products-block/assets.

    class=”wp-block-woocommerce-all-reviews wc-block-all-reviews has-image has-name has-date has-rating has-content has-product-name”

    A little help if you can please.
    Thank you

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Author Optimizing Matters

    (@optimizingmatters)

    First and foremost try to identify what is breaking things by just disabling CSS or JS or HTML or Image optimization (incl. lazyload). Based on that we can see what the next steps need to be 🙂

    frank

    Thread Starter underro

    (@underro)

    Is JS

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    OK, try these adding this to the comma-separated JS optimization exclusions:

    
    wp-includes/js, plugins/woocommerce-gutenberg-products-block/, plugins/woocommerce

    if it does not work have a look at the browser console to see what JS errors are shown.

    Thread Starter underro

    (@underro)

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    that’s merely a notice, not an error. nothing else?

    Thread Starter underro

    (@underro)

    At the moment I have removed those exclusions, because it created other problems for other java.

    Thread Starter underro

    (@underro)

    After I put those exclusions, the filter is no longer displayed in Firefox (even after I cleared all browsers).
    I deactivated and reactivated, and now it works for filter.`

    • This reply was modified 1 month ago by underro.
    Plugin Author Optimizing Matters

    (@optimizingmatters)

    happy to read it is OK now underro 🙂

    have a nice day,
    frank

    Thread Starter underro

    (@underro)

    Ok back to the issue I opened the topic for,
    This is the site:

    I inserted the reviews in the page: /contact
    Some information:
    use for optimization combination between Autoptimize + Async JavaScript, Webcraftic Robin image optimizer and WP Fastest Cache (without any minify function, combine,)
    (For me, it was by far the best combination.)

    • This reply was modified 1 month ago by underro.
    Plugin Author Optimizing Matters

    (@optimizingmatters)

    easiest solution; install Autoptimize 2.9 beta (download from github here), enable the new “Enable configuration per post/ page?” option and then in the edit screen of the contact page disable JS optimization. that way you don’t need to add all those exclusions which are not needed on other pages (and would slow things down)? 🙂

    Thread Starter underro

    (@underro)

    Thanks a lot for the answers.
    Very fast.
    A good day.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    you’re welcome, feel free to leave a review of the plugin and support here! 🙂

    Thread Starter underro

    (@underro)

    Hello again.
    I downloaded the beta Autoptimize, but it seems that this is not the problem, even if I excluded from optimization page option, it did not solve (by the way, great the new options), but Async JavaScript is; when I disable, Java worked perfectly.
    The Async JavaScript settings are the ones with which the site worked perfectly and I had the best audit score. I excluded that plugin in “Plugin Exclusions” but I still can’t see the reviews elsewhere. In fact, it’s the only Java issue I’m dealing with.

    screencapture-habo-ro-wp-admin-options-general-php-2021-05-12-21_00_50

    • This reply was modified 1 month ago by underro.
    Plugin Author Optimizing Matters

    (@optimizingmatters)

    You’ll also have to exclude all of wp-includes/js from being Asynced @underro . But you could also try the new JS defer options in AO and/ or the Async field on the Extra tab instead of trying to tame AsyncJS?

    Thread Starter underro

    (@underro)

    Yes with “wp-includes / js” I solved.
    Thank you again.

Viewing 15 replies - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.