Support » Plugin: TablePress » Java not working?

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    thanks for your post, and sorry for the trouble.

    The reason for this is that either a plugin or your theme are using outdated versions of the jQuery JS library, see http://tablepress.org/faq/js-functions-not-working/
    In fact, your are even hit by this twice, as the theme AND a plugin are loading such outdated versions of jQuery.
    Please try suggestions in that link to fix this so that the latest version of jQuery, that comes with WordPress, is used. After that the JavaScript functions should work fine.

    Regards,
    Tobias

    Darn. This is so over my head..

    How do you install a new jQuery? How do you delete the old ones?

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    you won’t actually have to install a new jQuery, you will just have to change your theme and that plugin, so that they don’t load the old version.
    The link that I posted above contains some hints on what you could look for, in the header.php or functions.php file of the theme. It might also be something like
    wp_register_script( or wp_enqueue_script(.
    For the plugin that is also loading an old version of jQuery, you would be looking for e.g. http://ajax.googleapis.com/ajax/libs/jquery/ (the URL for the Google CDN).

    Regards,
    Tobias

    Thanks so much!

    I don’t see JQuery in ‘header.php’.. But I see it in several places in ‘functions.php’.. Should I just delete all the lines containing Jquery?

    Well. I deleted:

    function theme_update_jquery_scripts() {
    if(is_admin()) {
    return;
    }
    wp_deregister_script(‘jquery’);
    if (theme_get_option(‘theme_iclude_scripts_from_cdn’)) {
    wp_register_script(‘jquery’, ‘https://ajax.googleapis.com/ajax/libs/jquery/1.7.1/jquery.min.js’);
    } else {
    wp_register_script(‘jquery’, get_bloginfo(‘template_url’, ‘display’) . ‘/jquery.js’);
    }

    And now my whole website went down… ::sigh:: oh well. I guess I might need to do a clean install or something.. Hopfully I got my backups updated.. ::facepalm::

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    yes, that looks like the correct function! Nice find already!
    The issue might simply be that you need to delete one more } right after where you already deleted this function.

    Regards,
    Tobias

    It made my whole wordpress stop working, and I need to put it back up from backup.. Lol.. No worries, I’m just going to use tablepress with another wordpress website, not this one.

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    sorry about that. It really shouldn’t be too hard to fix, but I assume that you don’t have FTP access at the moment? That way, you could fix that } rather easy.

    Regards,
    Tobias

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Java not working?’ is closed to new replies.