WordPress.org

Forums

[resolved] January 1 1970 shows on post after upgrade (20 posts)

  1. cj little
    Member
    Posted 1 year ago #

    I am having a bit of trouble. I was using a previous word press version and my host forced me to get the latest. I had no issues at all with my combination, Word press, Thesis 182 from DYI and events calendar pro.
    After the upgrade all looked good except when I went to a post there was a "Start: January 1, 1970 12:00 am" right under the post header. Now I don't feel my readers are so lame that the date would be a real issue but I would rather it was not there or that it was a real date from the event calendar if the post is linked. (many are not) Is there some help on this? Here is the post link http://www.mostwondrous.com/2013/10/07/san-diego-november-16-class-tbd/ This is not an event linked post but it could be. There is an event with the same name. I used to make a post then go to events and make a event with all the information. The events all work fine but the posts do not.

  2. Tara
    Member
    Posted 1 year ago #

    Have you tried:
    - deactivating ALL plugins temporarily to see if this resolves the problem. If this works, re-activate them individually (one-by-one) to find the problematic plugin(s). If you can't get into your admin dashboard, try deactivating via FTP or SFTP or whatever file management application your host provides. If applicable, also remember to deactivate any plugins in the mu-plugins folder. The easiest way is to rename that folder to mu-plugins-old.
    - To rule out any theme-specific issue, try switching to the unedited default, core-bundled Theme (such as Twenty Twelve or Twenty Thirteen) for a moment using the WP dashboard. If you don't have access to your admin area, you can switch to the default theme by renaming your current theme's folder in wp-content/themes and adding "-old" to the end of the folder name using via FTP or SFTP or whatever file management application your host provides. Alternately, you can remove other themes except the default theme. That will force your site to use it.
    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems (because the hooks remain unless plugins completely removed or some plugins stick around in cached files. So by renaming the folder, you break them and force them inactive).

  3. cj little
    Member
    Posted 1 year ago #

    All good points and tried no change. Unfortunately I have no posts when using the WP themes so I could not tell if that helped. The one consistent troubleshooting tactic I have used for the last thirty years is the addage look to the last thing you did first. The last thing was the upgrade. All else was working fine. I would just like to know what is making the call and make it stop. It is my understanding that WP is the calling agent and that the code for the page is established by WP.
    If I look at the page and its code there is a call for Start and another for that date but the date defaults to the beginning of 4 byte time because Events calendar pro does not return a valid date because the post has no dates for it. Does anyone know which css in WP calls for dates and why a post would do this without having any code for it?

  4. WPyogi
    Forum Moderator
    Posted 1 year ago #

    Is Thesis 1.8.2 compatible with WP3.7+?

    Have you asked DIY themes?

  5. cj little
    Member
    Posted 1 year ago #

    The fine folks at DYI say there should be no issues but that upgrading to their latest would only take about three days and compound the problem ....Having looked at this for three nights I just twigged on the fact that somehow every blog post is being treated as an event. I would assume I must have some silly setup that is using the Events calendar page settings for single page and not the thesis blog posting single page???
    By the way I would like to thank all who are being so responsive to my admittedly small obsessive issue. Thank you Tara, good information and a great way to start looking for any issue. WPyogi..what can I say except thanks for being there for all of us, volenteer is such a thankless job.

  6. WPyogi
    Forum Moderator
    Posted 1 year ago #

    I must have some silly setup that is using the Events calendar page settings for single page

    Yeah, I'd tend to agree that sounds likely - but since you're using a paid version of the plugin - have you asked them? It still doesn't seem like it should be getting a 1970 date!?

    BTW, are you sure your dates in other places are working correctly?

    (Thanks for your appreciation, though I'd feel better if we can help you get this solved :) ).

  7. cj little
    Member
    Posted 1 year ago #

    I have checked all other dates and they are good All the event pages show the correct start and end dates and times as they should. Just the blog posts have that 1970 date. The guys at calendar say it is most likely some WP thing that the upgrade made happen.

  8. WPyogi
    Forum Moderator
    Posted 1 year ago #

    The guys at calendar say it is most likely some WP thing that the upgrade made happen.

    Hmm, well, since that's a commercial theme and a commercial plugin (these forums don't support commercial products partly because we don't have access to them), it's unlikely that anyone here will be able to really figure that out.

    But you can probably hide that line of text using CSS - see if this works - though it may hide other things (might need to modify the CSS to target that page) - so check around:

    #tec-event-meta {
        display: none;
    }
  9. Krishna
    Volunteer Moderator
    Posted 1 year ago #

  10. cj little
    Member
    Posted 1 year ago #

    Well we don,t know what caused it but Just wanted to follow up on this post. We never solved it and reinstalled everything, WP, Thesis and ECP, into a new directory at the host site. Works fine and we may never know what the problem was. Thanks for the help. This did not correct the older posts but the new ones work correctly so...alls well here

    Oh yeah if you want to install ECP you must use (we had to anyway) Matt Hodder's mods to get the formatting correct.
    Thanks for your help and advise.

  11. cj little
    Member
    Posted 1 year ago #

    I may have spoken a bit fast here. It seems the blog posts are still being treated as events and the Start date still shows as jan 1 . No dates are assigned to posts as far as I know. Does anyone Know what selects the post type I would think WP selects with the WP dasheboard stating posts and another section for events.

  12. Tara
    Member
    Posted 1 year ago #

    Try this:

    Look for this CSS Rule in your theme's style.css file:
    #tec-event-meta {

    Add this property to the above rule:
    display:none;

  13. WPyogi
    Forum Moderator
    Posted 1 year ago #

    Does anyone Know what selects the post type I would think WP selects with the WP dasheboard stating posts and another section for events.

    Those are theme/plugin specific.

  14. cj little
    Member
    Posted 1 year ago #

    I did not find that rule in the style.css for this thing.
    I did however find in the events .css file this bit.,
    #tec-content a, #tec-event-meta a {
    text-decoration:none;
    When I examine the code Q on the post This seems to be the call slso in the event css
    .events-archive .entry-title a, .tec-event-meta-desc, .tec-event-day {
    color:#333;
    }
    .events-archive .hentry {
    margin:0;

  15. Tara
    Member
    Posted 1 year ago #

    you may try appending this to the bottom of your theme's style.css file:

    #tec-event-meta { display:none;}

  16. cj little
    Member
    Posted 1 year ago #

    nope that did not change anything. It still seems that the WP dashboard is either nor recognizing a post or some how thinks all posts are events

  17. WPyogi
    Forum Moderator
    Posted 1 year ago #

    I don't see any event date on that post anymore.

  18. Tara
    Member
    Posted 1 year ago #

    I don't see it either!
    Try flushing any caching plugins you might be running, as well as server and/or browser caches. To clear cache in your browser, press clrl+f5 keys simultaneously. Also, try different computer/different browser.

  19. cj little
    Member
    Posted 1 year ago #

    Magic I guess, I think it was the addition of that rule Which Tara prompted. Looks ok now on all fronts.
    Thanks to all who spent even a moment on this issue. Just goes to show many minds working together solve faster.

  20. cj little
    Member
    Posted 1 year ago #

    Thanks again.

Topic Closed

This topic has been closed to new replies.

About this Topic