Support » Plugin: Einsatzverwaltung » Jahresarchiv setzt den post_type nicht auf Einsatz

  • Resolved josefkoerner

    (@josefkoerner)


    Hallo,

    ich baue gerade eine neue Seite für unsere FFW Geiselwind. Ich finde das plugin super.

    Ein Problem taucht bei mir auf:
    Über die Datei archive-einsatz.php erstelle ich mir die Archivseite. Funktioniert soweit. Auf der Archivseite ist auch der Einsatzjahre shortcode. Funktioniert auch.

    Im Frontend funktioniert https://ffw.topfbraeu.de/einsatzberichte/ perfekt. Die Liste mit allen Einsatzberichten wird angezeigt.

    Wenn ich nun auf eine Jahreszahl (z.B. 2022) clicke, wird die URL https://ffw.topfbraeu.de/einsatzberichte/2022/ aufgerufen. Jetzt rendert das System allerdings die Beiträge aus dem Blog also Aktuelles anstatt der Einsatzberichte.

    Habt ihr eine Idee was da schief gehen könnte?

    Version 1.10.0
    WP Version 5.8.2
    PHP 7.4.27

    Viele Grüße,

    Josef

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Andreas Brain

    (@abrain)

    Hallo Josef,

    ich bin mir nicht ganz sicher, wo da der Hund begraben liegt.

    Selbst wenn man explizit den post_type setzt, gibt es dieses Ergebnis: https://ffw.topfbraeu.de/?post_type=einsatz&year=2022 bzw. https://ffw.topfbraeu.de/2022/?post_type=einsatz

    Könnte auch sein, dass sich hier die Einsatzverwaltung und ein anderes Plugin ins Gehege kommen. Das Theme scheint es auf den ersten Blick nicht zu sein. Zumindest in der kostenlosen Variante konnte ich den Effekt bei mir nicht beobachten.

    Löst sich das Problem, wenn alle anderen Plugins deaktiviert werden? Falls ja, schrittweise die Plugins aktivieren und schauen, wann es wieder auftritt.

    Viele Grüße,
    Andreas

    Thread Starter josefkoerner

    (@josefkoerner)

    Guten Morgen Andreas,

    herzlichen Dank für deinen Tipp! Ich hab das durchprobiert – und tatsächlich: das plugin “Better File Download”.

    Das plugin verwende ich seit Jahren auf anderen Seiten und hab es mit meinem Template rein kopiert. Jetzt hab ich festgestellt, dass die Pflege des Plugins vom Author schon vor einiger Zeit eingestellt wurde. Mein Fehler. Gibt mir zu denken, wie sinnvoll so Templates sind.

    Nochmals vielen Dank! Jetzt funktioniert es wie gedacht 🙂

    Plugin Author Andreas Brain

    (@abrain)

    Hallo Josef,

    super, dass es wieder klappt!

    Und ich bedanke mich ebenso 😉

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Jahresarchiv setzt den post_type nicht auf Einsatz’ is closed to new replies.