WordPress.org

Support

Support » Plugins and Hacks » Change DB Prefix » I've got a proble, Can I reverse the changes ASAP?

I've got a proble, Can I reverse the changes ASAP?

  • Hi,
    I ran this plugin on a WP site and got the following errors –
    Changing value: mdv_user_roles in table mdv_options: Failed
    Changing values in table mdv_usermeta: Failed

    Is there a way to quickly reverse to original prefix?
    Thanks!

    http://wordpress.org/plugins/db-prefix-change/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Some more info –
    This is what is happening now –
    Whether I try to log into my /wp-admin or just access domain directly I am redirected to /wp-admin/install.php (welcome screen to install WordPress) as if this is a new installation.

    Findings –
    I logged into myPHP from cPanel and found that all tables have old prefix, which means none of the tables are changed to the new one. Makes sense, probably there was a db-rollback due to the db errors.
    However, $table_prefix property in wp-config.php file was changed to new prefix. I changed it back to the old prefix and uploaded file to server.

    I still get the same behavior though. Access to domain points back to /wp-admin/install.php file.

    Anyone has come across this issue? Any help is greatly appreciated!

    WordPress version being used is 3.7.1

    Figured the answer. To start with I was looking at the wrong DB and thinking that tables were not renamed by the plugin. They were.

    Basically ‘Change DB Prefix’ seems to be a badly written plugin.

    Cause –
    It was able to rename tables but somehow it appears to have added another ‘_’ to the new prefix. And hence it could not rename the field values in <prefix>_usermeta table.

    Funnily enough the original prefix given for the plugin itself was wrong, in the sense there were no tables with the given ‘original’ prefix! So the plugin went and created another duplicate bunch of tables.

    Basically db automicity was not maintained by this plugin. Makes me wonder how does one miss such basic principle of db mgmt and release a plugin.

    Solution –
    After analyzing the issue with ever helpful Bluehost tech support, just dropped new tables and modified db_prefix in wp-config.php back to original value. This solved the problem.

    No idea why it didn’t work for you, but I’ve used it on a number of sites, with different versions of WordPress and never encountered any problems. Just now used it on WP 3.8 for the first time and again, no problems.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘I've got a proble, Can I reverse the changes ASAP?’ is closed to new replies.
Skip to toolbar