WordPress.org

Support

Support » Installation » I’ve got a Parse error after uploading/Please Help

I’ve got a Parse error after uploading/Please Help

  • Parse error: syntax error, unexpected $end in /home/successw/public_html/wp-includes/functions.php on line 2182

    Thanks for helping

Viewing 12 replies - 1 through 12 (of 12 total)
  • reupload that file. make sure your ftp client is set to upload text files in ascii mode.

    and if youre confused by the path to the file, relative to your wordpress files, you are looking for this:

    /wp-includes/functions.php

    i reuploaded that file and it still the same error parse message.

    then do it again. try another ftp client.

    another solution? is not working.

    that IS the solution.

    what are using as as your normal ftp client?
    what was the SECOND ftp client you used?

    Remember I suggested that.

    if you cant figure out how to upload files properly, maybe you need to think about using wordpress.com or paying someone to set up your site.

    filezilla and i tried smartftp.

    filezilla has no trouble uploading text files in ascii mode. have you confirmed that its doing that? if so, how have you done so?

    if your host offers some sort of control panel access, check to see if they have a web based file uploader area.

    also, unzip the wordpress zip again. in other words, make sure that the files you are uploading are NOT the problem.

    should i download wordpress again an try to reupload it? because i on’t know what happened i just followed the installation procedure.
    but it is giving me that message when i try to launch the installation.
    http://www.successwizard.info/wp-admin/install.php.

    i tried to download wordpress again and i used my host file manager to download the function.php file but is not working.

    englishcoder
    Member

    @englishcoder

    I’ve had a similar problem to this before.

    Try setting the default WP theme; if you can’t load WP then just rename the current themes’ folder on the server – this will reset to the default theme (note: you should now be able to login to WP admin, once there go to Appearance > Themes and you’ll get a message saying the current theme is broken, reverting to default).

    If this works, make sure there are no spaces in the themes’ .php files before the opening <?php tag and after the closing ?> tag.

    Worst case scenario, try uploading WP to a subdirectory / sub domain / / dirrerent domain /localhost and see if the same error occurs. Make sure you download a “fresh” version of 2.8.4 (current latest).

    Hope this helps!

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘I’ve got a Parse error after uploading/Please Help’ is closed to new replies.