I've corrupted my WP Blog (7 posts)

  1. katiebird
    Posted 10 years ago #

    I did something to my wordpress files -- and I can't remember what exactly. The end result is that I can't seem to load the blog and I don't know what needs to be fixed.

    I'm currently getting these error messages:

    Warning: main(--path --/wp-includes/wp-l10n.php): failed to open stream: No such file or directory in --path --/eat4today.com/wp-settings.php on line 117

    Fatal error: main(): Failed opening required '/hsphere/local/home/katiebir/eat4today.com/wp-includes/wp-l10n.php' (include_path='.:/usr/local/lib/php') in--path --/eat4today.com/wp-settings.php on line 117

    I've backed up the database and looked at it, it seems like everything is there. And I tried restoring the files from the originals. But none of these things worked and I'm still getting the error.

    I have an inactive wordpress blog and I wonder if it would help to try using the database from my regular site at this other blog so I can test to see if the database is all right. What steps would I need to do to have this second site use the database.

    Is there some way to get things working again -- keeping my data? Or is that lost?

    Thank you for your help.

  2. Direkt
    Posted 10 years ago #

    Okay, maybe did you move your WordPress folder?

  3. Kafkaesqui

    Posted 10 years ago #

    Direkt is pointing out this is not a database problem, but one with a php file. Do you have a wp-includes/wp-l10n.php file?

  4. katiebird
    Posted 10 years ago #

    Yes, I do have a wp-includes/wp-l10n.php -- although one of the messages implies that I don't.

    And no, I haven't moved the files.

  5. katiebird
    Posted 10 years ago #

    I was thinking about reinstalling the files, but all the steps start out with deactivating plugins. And I can't do that since I can't get into the site admin.

    Unless there is a way to do that through PHPMyAdmin editing the database?

  6. Kafkaesqui

    Posted 10 years ago #


    I don't see wp-l10n.php there (in fact, you seem to be missing a number of files). I'd delete everything in that directory, and re-upload all the files from the installation zip file found in wp-includes/.

  7. katiebird
    Posted 10 years ago #

    Wow-- I could have sworn that I checked that (really) & that a friend did as well. I deleted both the wp-admin & the wp-includes folders and replaced them from another working set. N

    Thank you very, very much.

Topic Closed

This topic has been closed to new replies.

About this Topic