WordPress.org

Forums

Blubrry PowerPress Podcasting plugin
[resolved] Itunes not recognizing my validated feed (6 posts)

  1. SkyWayne
    Member
    Posted 10 months ago #

    Hey everyone,

    I'm trying to create my first podcast, and I keep this message from Itunes when I submit my feed:

    "Podcast cover art must be at least 600 X 600 pixel JPG or PNG, in RGB color space, and hosted on a server that allows HTTP head requests"

    This is my podcast feed: http://www.mwpatton.com/feed/podcast/

    I have uploaded the required 1400 x 1400 artwork, so I am at a total loss as to what the problem might be. Any suggestions and/or advice would be very much appreciated.

    Thank you!

    https://wordpress.org/plugins/powerpress/

  2. SkyWayne
    Member
    Posted 10 months ago #

    I figured it out . . . my htaccess file didn't allow hot linking, and that was throwing everything off.

  3. kpurcell
    Member
    Posted 3 weeks ago #

    I've had this same issue. How did you fix this?

  4. Angelo Mandato
    Member
    Plugin Author

    Posted 3 weeks ago #

    kpurcell, what is your feed URL? It may not be the same issue.

    The half baked solution for hot linking is to block links that do not have a referrer. I can tell you podcasting uses HTTP to transfer feeds and media files, but it does not use any web browser or link navigation, which means there is no Referrer data when feed / media URL requests are made. So if you have a solution that is preventing hot linking and you want to podcast, then you're going to have to turn off the hot linking features, at least to where your media files and feed URL.

    There are lots of other reasons for a feed not to work. Aggressive mod_security settings on the server or even a WP security plugin can prevent it from working correctly. If you share the URL I can look at it and tell you what the cause is.

  5. kpurcell
    Member
    Posted 3 weeks ago #

    I switched to another WordPress itunes podcasting plugin and it's working. I think the plugin I was using was broken.

  6. Angelo Mandato
    Member
    Plugin Author

    Posted 3 weeks ago #

    kpurcell, if you were able to switch plugins in only 15 minute time period to fix the issue, then the issue was more than likely something to do with server caching than with any one plugin.

Reply

You must log in to post.

About this Plugin

About this Topic