WordPress.org

Forums

Seriously Simple Podcasting
[resolved] iTunes 404 (4 posts)

  1. growsocial
    Member
    Posted 2 years ago #

    When trying to submit my feed to iTunes, I get this error "We had difficulty reading this feed. Bad http result code: 404".

    Any ideas on how to fix this? Thanks!

    http://wordpress.org/extend/plugins/seriously-simple-podcasting/

  2. Hugh Lashbrooke
    Member
    Plugin Author

    Posted 2 years ago #

    Firstly, Make sure you are using the feed URL found in your podcast settings to submit the feed to iTunes. Secondly, this 404 error can happen if you have no blog posts on your site - this is due to a bug in WordPress itself that I cannot effectively work around in all situations. If this is the case with you then just adding one published blog post will fix it for you.

  3. growsocial
    Member
    Posted 2 years ago #

    That explains it. Added a post, and it started working. Thanks!

  4. mhaofmt
    Member
    Posted 2 years ago #

    I had the same issue and a new post did not work.

    My issue was that the WordPress URL was different from the Site URL. Once I updated the feed url (e.g. http://sitename/wordpress/?feed=podcast) to match the site URL (e.g. http://sitename.org/?feed=podcast) itunes accepted the feed fine.

    Thanks for a great plug in!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Seriously Simple Podcasting
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.