WordPress.org

Support

Support » Plugins and Hacks » nrelate Most Popular » It's showing ALL the posts rather than those specified in settings

It's showing ALL the posts rather than those specified in settings

Viewing 12 replies - 1 through 12 (of 12 total)
  • katrina@nrelate

    @katrinanrelate

    nrelate Support Rep

    @marcelo Pedra — I checked it out and in our database it looks like Most Popular is still set to pull entries from as far back as 10 years into your archive. Can you please go into your settings for Most Popular and double check that you save this setting to 2 years?

    – Katrina @ nRelate

    I set it to 1 Year.
    But wait, do you use XML RPC to communicate with my site? or is it sending the data to your sever? I say this because I dont use XML RPC and disabled it two weeks ago…

    katrina@nrelate

    @katrinanrelate

    nrelate Support Rep

    @marcelo Pedra — whenever settings are changed, our servers get pinged. We’re still seeing MP set to 10 years in our database.

    – Katrina @ nRelate

    Well that’s weird. A bug, I’d said.

    It said 1 year on my end. Now changed it to 2 Years:
    https://www.dropbox.com/s/4ytq4ae43n3bhe0/Most%20Popular%20screen.png

    What can you see now on your end?

    Do you rely on XML RPC to connect in any way to my site? Because I deactivated it for security reasons.

    katrina@nrelate

    @katrinanrelate

    nrelate Support Rep

    @marcelo Pedra — We don’t use XML RPC to connect to your site. Thanks for providing a screenshot of your settings – I now see that the maxageposts for MP has changed to 2 years. How does MPW look for you now?

    – Katrina @ nRelate

    Hi. It is still showing posts from several years ago…
    You can test it yourself by visiting marcelopedra.com.ar/blog
    I guess this is something only you guys can fix from your end, right?

    katrina@nrelate

    @katrinanrelate

    nrelate Support Rep

    @marcelo Pedra — This looks like a bug on our end. We’re troubleshooting the issue further and I’ll let you know once it’s been fixed.

    – Katrina @ nRelate

    Great. Glad to help. I’ll be around to test your next release. Thanks!

    katrina@nrelate

    @katrinanrelate

    nrelate Support Rep

    @marcelo Pedra — Spoke with tech. Most Popular’s maxagepost is very different from any of our other plugins’ maxagepost.

    MPW’s maxagepost determines how far back in time we should track “views” on their pages to calculate the most popular article. For ex. if I have maxagepost set to 5 years, and a post from 6 years ago has the most views, it will show up in the list of most popular units.

    – Katrina @ nRelate

    @katrina – And why is that the default behaviour? I think you should allow the owner to force the max age. What if I want to highlight most popular posts from one year ago without showing old, irrelevant, posts, even if they were the most popular sometime ago?

    Can you add an option to allow force this decision? (Please?) I know other owners would appreciate this.

    BTW, I just noticed a weird style was released, what just happenned? do you control the css from your server?
    https://www.dropbox.com/s/uwd7q9cy9axlu95/mpw%20wtf.jpg

    katrina@nrelate

    @katrinanrelate

    nrelate Support Rep

    @marcelo Pedra — I’ve put in a feature request to see what we can do about allowing users to set how far back in the archive we go for Most Popular posts for a future build of our plugin.

    We’ve also fixed the formatting issue and Most Popular looks good on your site now: https://www.dropbox.com/s/on3nx76b4vr9um0/Screenshot%202014-04-23%2011.18.15.png

    – Katrina @ nRelate

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘It's showing ALL the posts rather than those specified in settings’ is closed to new replies.
Skip to toolbar