WordPress.org

Forums

MailPoet Newsletters
[resolved] It's sending newsletters twice (yes, again!) (14 posts)

  1. Marcelo Pedra
    Member
    Posted 11 months ago #

    Hello guys. I'm aware you recoding the entire plugin to leverage the quality, but in the meantime, I noticed that if I'm browsing my WP while the plugin start sending one newsletter, it will trigger the sending of another one! The same one, so people is receiving it twice.

    This is happenning with the automatic newsletter set to send daily posted articles to the subscriptors. And it's bugging them, causing people to sign out.... so please help. asap :)

    Here is the features you MUST add asap for upcoming version:
    1) Some kind of semaphorization for automatic newsletters, so that the plugin has awareness of any automatic newsletter currently being sent.
    2) The same way you can Pause a newsletter on the go, you should add a button to ABORT that send process. Simply deleting the duplicate newsletter doesn't make comfy will mess things and stats, because those who received the duplicated one will open one of them randomly and find broken images. Again, people running away of you.

    And 3) now that I remember, the welcome email than can be set to be triggered immediately people is registered as user in WP, and selectively sent by user role, is not being sent ALWAYS. Not sure what is stopping it, but sometimes it is sent, and sometimes don't. And vast majority of times it doesn't. I have a site with 1800 users and this solely problem could lead me to migrate to another email solution rather than purchase de Premium version.

    I've found some other minor bugs in the UI and I reported them to Rafael some time ago. Still not fixed.

    Can you fix this please please please?

    https://wordpress.org/plugins/wysija-newsletters/

  2. ScytheZ
    Member
    Posted 11 months ago #

    I can confirm .. again it's sending mails twice (instead of one / day for me). At least it's not a triplicate like a month ago.

  3. rogerbooyou
    Member
    Posted 11 months ago #

    Same here.

    I'm running some tests on the "backstage" with some personal emails of my own.

    Weekly newsletters are fine but, as for today [08/06/2014], my daily newsletter are been sent twice - yesterday I received it 13 times!!!.
    -
    I received 13 [daily] emails when a had "With Send with..." set to "Third party" - I was using my Google Apps SMTP.

    I changed the settings to "With Send with.../Your own website".
    Now, just like Marcelo Pedra, daily emails are been sent twice.

    I'll write you guys an email. Just wanted to keep the record here.

    Thank.

  4. Marcelo Pedra
    Member
    Posted 11 months ago #

    Roger: I saw the duplicated newsletter no matter if I use my own server or Amazon SES. I gave access Rafael Ehlers to my WP almost two months ago and said they will be taking this bug into consideration to be fixed. No more news since then.

    ALTHOUGH, I can confirm that duplicating issue DOES NOT HAPPEN WITH THE PAID VERSION. I have three clients who purchased a license and it is working perfectly. From the server, and from Amazon SES.

    Hope they read this. :)

  5. Marcelo Pedra
    Member
    Posted 11 months ago #

    For the licensed version, the plugin download a premium version of the plugin, SO..... the free version is having the crazy issues.

  6. rogerbooyou
    Member
    Posted 11 months ago #

    Marcelo: Well, i'm an situation that I can't recommend the premium version if the basic one is not working properly.
    -

    There was a WordPress updated last night: 3.9.2 - let's see if there's any change.

    -

    For now:

    - I have a daily schedule to fire in 3 hours [I'll post here a follow up].
    - No "send immediately" newsletter was fired after 2 posts were published [one last night, the other early this morning].
    - Weekly newsletters are OK.

  7. rogerbooyou
    Member
    Posted 10 months ago #

    Duplicated newsletter:

    After WordPress update [3.9.2] the issue is gone.

    Send immediately:

    I had to create a new Newsletter [not duplicate], now it's working.

  8. Marcelo Pedra
    Member
    Posted 10 months ago #

    I can confirm that WP 3.9.2 and last version of MailPoet is sending newsletters fine. No duplicates anymore, yet.
    Hopefully, it has been fixed now.

  9. MailPoet Staff
    Member
    Plugin Author

    Posted 10 months ago #

    Hi Guys,

    Duplicates will stop as soon as you have MailPoet cron activated. If you don't have it activated, duplicates can happen because of the heavy visited websites. It doesn't matter if it's on a free version or on the Premium version, we always have this "issue", that's why we always recommend people to make sure MailPoet cron is activated.

  10. Marcelo Pedra
    Member
    Posted 10 months ago #

    @MailPoet Staff:
    I had MailPoet's cron deactivated and the duplicated newsletters have been solved. I cannot recall when I have deactivated that option. Maybe one month ago. I'll activate it again and see how it works this week and let you know what happens. My site send automatic newsletters almost every day.
    Best regards

  11. Marcelo Pedra
    Member
    Posted 10 months ago #

    Well, it's me again. I activated the MailPoet's Cron and the duplicated emails gone bad again. So, I will deactivate your cron since it's evident that something is going bad with it. Automatic post feed newsletters was working good until I activated this thing.
    Hope you can fix it soon. Anyway, having it deactivated works very well for me.

  12. Olga_i
    Member
    Posted 4 weeks ago #

    I am having this same issue, with the crons activated or deactivated, the duplicate emails still go out. I have been told by the MP support that it may be caused by another plug in, but I have deactivated them all and tested, and nothing helps. Anyone been able to come up with a fix for this? If so please share. I am having the same issue with clients getting annoyed with the duplicates.

  13. rogerbooyou
    Member
    Posted 3 weeks ago #

    Well, Olga_i, unfortunately I had to move on and switched to MailChimp.

  14. Marcelo Pedra
    Member
    Posted 11 hours ago #

    The only way I found to avoid duplicate emails being sent, is by closing all the tabs of the website before the scheduled time of sending.
    If for some reason you have any page/post edition page opened, the newsletter will be sent twice... or even thrice!!!!

    Couldn't check if this is happening also with premium version.

Reply

You must log in to post.

About this Plugin

  • MailPoet Newsletters
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.