Support » Requests and Feedback » It's 2013! Why don't BR tags work properly!?!?!?

  • When I intentionally add <br> tags while in the text editor portion of the post or page editor, I’ve done it for a reason. I’m seeing posts from people complaining about this crap going back over 2 years…

    No other form of hacking it with <p> tags or nbsp;’s is acceptable. Wtf?

    Does anyone know of a way to hack the core (because that should be necessary for something like this?) to stop the damn editor from screwing up such a simple html tag?

Viewing 9 replies - 1 through 9 (of 9 total)
  • esmi

    (@esmi)

    Forum Moderator

    Which editor are you using?

    The default one that comes with wordpress.

    esmi

    (@esmi)

    Forum Moderator

    Text or Visual?

    …while in the text editor portion of the post or page editor….

    When in the text edit mode, not the visual side. If I ad <br><br><br> I only get one line break instead of 3.

    esmi

    (@esmi)

    Forum Moderator

    Have you checked that this isn’t a CSS line-height issue?

    It would help if you could link to page which illustrates the issue you’re describing.

    Chris Olbekson

    (@c3mdigital)

    Level 12 Bug Squasher & Forum Moderator

    You can remove the `wpautop’ filter from the content then replace it setting the $br param to false which will allow you to add multiple br tags after paragraph breaks.

    remove_filter( 'the_content', 'wpautop' );
    
    add_filter( 'the_content', 'pee_allow_br' );
    function pee_allow_br( $content ) {
        $content = wpautop( $content, $br = false );
        return $content;
    }

    I suggest you to use the <br/> tag and nothing else…
    This simply works!

    Chip Bennett

    (@chipbennett)

    Theme Review Admin

    When in the text edit mode, not the visual side. If I ad <br><br><br> I only get one line break instead of 3.

    Do you, by chance, switch between the HTML and Visual editors?

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘It's 2013! Why don't BR tags work properly!?!?!?’ is closed to new replies.