Support » Plugin: iThemes Security (formerly Better WP Security) » iThemes Security PHP 7.2 Compatibility test

  • FILE: /var/www/test.site/wp-content/plugins/better-wp-security/lib/index.php
    ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
     1 | WARNING | No PHP code was found in this file and short open tags are not allowed by this install of PHP. This file may be using short open tags but PHP does not allow them.
    ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
    
    FILE: /var/www/test.site/wp-content/plugins/better-wp-security/core/admin-pages/page-debug.php
    -------------------------------------------------------------------------------------------------
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    -------------------------------------------------------------------------------------------------
     372 | WARNING | INI directive 'safe_mode' is deprecated since PHP 5.3 and removed since PHP 5.4
    -------------------------------------------------------------------------------------------------
    
    FILE: /var/www/test.site/wp-content/plugins/better-wp-security/core/img/index.php
    ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
     1 | WARNING | No PHP code was found in this file and short open tags are not allowed by this install of PHP. This file may be using short open tags but PHP does not allow them.
    ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
    
    FILE: /var/www/test.site/wp-content/plugins/better-wp-security/index.php
    ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
     1 | WARNING | No PHP code was found in this file and short open tags are not allowed by this install of PHP. This file may be using short open tags but PHP does not allow them.
    ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

    Maybe you can add this code in index.php files for fixing some warnings:

    <?php
    // Silence is golden.

    iThemes Security 7.2.0
    PHP Compatibility Checker 1.4.6

Viewing 8 replies - 1 through 8 (of 8 total)
  • I’m seeing the same errors after updating to the latest version. I’m in the process of upgrading a number of client sites to PHP 7.2. It would be great to get a response to know if the plugin is PHP 7.2 compatible.

    Thanks in advance.

    any news on this?

    7.2 gives a range of wp-cli erros as well. Swapping back to 7.1 and wp-cli works fine again.

    Developers will speak on the topic? The important point is that earlier versions are no longer supported.

    I’d like to know the answer to this too, as I have more than one site I want to upgrade to PHP 7.2.

    @abrightclearweb
    This is not critical warnings. On my website the plugin is working good on PHP 7.2.

    I posted it just like recommendation for code improvements.


    @pietpompies
    I don’t know about compatibility with wp-cli on PHP 7.2, because I’m not using it.

    We’re using SiteGround (PHP 7.3) and iThemes Security Pro. No issues.

    Do note that the free plugin has a 3 month lag compared to the Pro release …
    Yep, that means the Pro plugin is more up to date …

    Update: (please refer to my previous post)

    We stopped receiving notifications (emails) from iThemes Pro a while ago (just noticed) so we downgraded our PHP level down from V7.3.6 to V7.1 (stable, safe, recommended by SiteGround).

    We’ll sit on this for a week to see if Notifications come back. Stay tuned for more updates.

    @nlpro @airathalitov @abrightclearweb @kronos1705 @pietpompies

    Are you receiving notification alerts (emails) from iThemes/iThemes Pro with no issues?

    Cheers!

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.