Support » Plugin: iThemes Security (formerly Better WP Security) » itheme Security Plugin – wp-content – broken website

  • Resolved Klika Inspirations


    I’m using the Itheme Security plugin and I changed the wp-content to a personalised one and it crashed my entire website. All I can see now is a blank page. When I log in to my wordpress back office, everything is gone, I have no plugins, no images, no contents.

    I tried to change manually the name back to wp-content from my htdocs files on hosting provider but still does not work.

    The website is

    How can I fix it?

    Please help!!!

Viewing 7 replies - 1 through 7 (of 7 total)
  • I have deleted 2 lines from my wp-config and it resolved the problem. thanks for help!

    The same thing happened to me. My directory name was changed, but WordPress wouldn’t access any of the info. I was able to change the directory name back on the server to get it back. It forced me to re-enable other plug-ins and settings though.

    What lines did you have to delete?

    Based on our conversation in this thread

    The 2 lines were:

    define ('WP_CONTENT_FOLDERNAME', 'assets');

    Note “assets” is the custom name given to wp-content folder.

    @klika Inspirations!
    Everything working fine. Don’t panic. You have two options to bring your site’s backend to the previous state. First, what you would like to expect from renaming the wp-content directory? Do you want to continue with the renamed directory or want to revert to the default wp-content?
    For the first case you can continue with the present setup but you must follow the following two steps.
    Step1: Goto the backend change wp-config.php file permission to writable that is at least 644 file permission
    Step2: Add the following four lines to the wp-config.php

    define( 'DISALLOW_FILE_EDIT', true );
    define( 'BWPS_FILECHECK', true );
    define( 'WP_CONTENT_DIR', '/home/your-cpanel-username/public_html/wp-root-directory-name/custom-wp-content' );
    define( 'WP_CONTENT_URL', 'http://your-domain-name/custom-wp-content'

    Note: You must change the following in the above four lines
    1.change your home directory name
    2.change your cpanel username
    3.change wp-root-directory to the directory name where your wp files installed
    4.change custom-wp-content to the name you renamed directory
    Now save wp-config.php and everything works fine as usual.

    If would like to revert wp-content folder the follow as below
    Step1: Make the renamed wp-content folder writable, means changing folder permission to writable
    Step2: Now rename the directory to the default one wp-content

    Now go to your backend. Hope every thing works find now.

    Let men know whether these instructions works for you or not.

    There is still an issue here with 4.0.21, basically same problem as already noted – and I’ve had it on 2 or 3 sites already. Although wp-config.php is editable for iThemes, it does NOT add the magic lines with define( ‘WP_CONTENT_DIR’ and define( ‘WP_CONTENT_URL’ when I tell it to change the directory. The directory (on disc) IS renamed, but WordPress never gets to know about it – white screen. Since iThemes is knocked out, subsequently nor does the own Login Slug work, making things confusing for less experienced users. Who then finds that they can log in at the “old” backend address, but that all plugins are deactivated since not found… Sure you can fix this by manually adding the two lines to wp-config, but a fix would be really great!

    Also, don’t forget to change the

    Settings >> Media >> Uploading Files>> “Store uploads in this folder” path.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘itheme Security Plugin – wp-content – broken website’ is closed to new replies.