Support » Plugin: BackWPup - WordPress Backup Plugin » It used to good, now its rubish!

  • I use it on 4 of my sites, it went from a pretty good and reliable backup plugin to a bloated mess, its basically broken, both in function (backups now run forever or fail, with update settings got lost, settings that used to work don’t anymore,…) and in the UI (before you could setup the backup on one page, now its multiple pages for every little thing, way more easy to get lost in the options), yeah really big step down!

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hi fanvid,

    thanks fo your feedback. As far as I get it BackWPup doesn’t work as expected for you and you don’t like the new UI. Is there anything particular our support can help you out with?

    oh if it was just me! my problem is that i liked backwpup and i have tried most backup plugins for wordpress and actually bought one, if the old 2.0 version of backwpup had sftp i would say it was perfect 5 start plugin!

    as of now the 3.0, with all the updates, it broke 2 of my sites, i still need to manually go click each time the plugin updates so it can congratulate me for updating from 2.0 (if i don’t do that it blocks the plugin and says i don’t have the required permissions), so i cant bulk update my sites, i have to update each one manually.

    the 3.0.1 and 3.0.2 updates were pretty bad, they broke previous settings and backups and had the unintended consequence of bomb mail me (because the update files were not in place), and even if backups go through i still get a ton of errors, timeouts, and other bizarre errors like (version 3.0.3):

    STRICT NOTICE: Declaration of OpenCloud\DNS\PtrRecord::Create() should
    be compatible with OpenCloud\PersistentObject::Create($params = Array)

    ERROR: Signal 15 is sent to script!

    Second process start terminated, because a other job is already running!

    or that it cant delete the old files on ftp, for no apparent reason… maybe because they were created with the 2.0 version?

    the backups are somewhat broken as well (i had 2 backups that were bad since this debacle, one was a database one and the other was the settings had apparently changed between updates), and we are talking about a backup plugin, i cant have all these problems, backups should run smoothly and be good.

    also the UI is cute but now setting up any backup takes 4 or 5 more steps than it used to and since you cant see all the options you have to go back and forth to make sure everything is set up properly, multiply that for 3 or 4 jobs per site and you got a whole lot of clicking around to get the job done and that’s besides having to check the overall settings and that’s besides the plugin forgetting settings.

    there you go some particulars, plenty more on the support forum.

    Hi fanvid,

    thank you, that’s already a lot of the topics we’re working on here. I can totally understand your disappointment, and I really hope we’ll be able to provide you with an update that works for your server environment.
    A couple of improvements we made to enhance security in 3.x ironically seem to mess with some server configurations and cause users trouble (while quite the opposite was intended). As BackWPup is a plugin that interacts a lot with its server environment, and server configurations vary a lot from host to host, it’s taking us time to sort things out, but we’re on it.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘It used to good, now its rubish!’ is closed to new replies.