WordPress.org

Forums

WordPress SEO by Yoast
It used to be so simple to say "Noindex" (10 posts)

  1. janaa
    Member
    Posted 1 year ago #

    How do I tell the plugin I don't want a post or page indexed?! It used to be so simple, but since upgrading to the lastest version of Yoast, I can't for the life of me work out how to do it!!

    My site is under development, and I have a site-wide noindex directive. But I still need to be able to flag individual posts or pages as noindex in preparation for going live ... and this option is no longer available under the Advanced tab!

    https://wordpress.org/plugins/wordpress-seo/

  2. anyway
    Member
    Posted 1 year ago #

    Same issue here. Please give us the noindex option on page and post level back!

  3. jrf
    Member
    Posted 1 year ago #

    We made the availability of the page/post specific setting dependent on the blog global setting as we found that too many people didn't understand why their blog was showing 'noindex' when they set it to 'index' on the post. Blog global settings should always be respected.

    I suggest changing the site-wide directive to index and protecting your blog until 'live' against indexing with a .htaccess IP protection layer.

  4. anyway
    Member
    Posted 1 year ago #

    Thanks for the clarification. I just want to exclude a few specific pages from indexing. "Imprint", "Copyright Policy" and "Terms and Conditions", for example. That should be possible with a plugin.

  5. free b2b market
    Member
    Posted 1 year ago #

    Put your path in robots.txt file. SearchEngine will dont crawl and index your website.

  6. jrf
    Member
    Posted 1 year ago #

    Or just untick the sitewide setting for five minutes, go to each of those those pages, change the setting and then re-tick the sitewide setting.

    While the box is not shown, settings are not deleted, so when you later untick the sitewide setting again, your page settings should be like you made them.

    Does that help ?

  7. anyway
    Member
    Posted 1 year ago #

    @jrf
    Ah, now I've got it! Thanks a lot for the hint!

  8. jrf
    Member
    Posted 1 year ago #

    Just an update: we've reversed this behaviour in the next version. You will see the dropdown, but also a warning about it being disregarded while your site-wide setting is no-index. Hope this helps.

  9. anyway
    Member
    Posted 1 year ago #

    Good decision... thank you!

  10. janaa
    Member
    Posted 1 year ago #

    Yes, good decision ... thank you!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WordPress SEO by Yoast
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags