Support » Plugin: Stop Spammers » it stops everyone accessing pages

  • Hello, nice plugin, it works very well maybe too much! 🙂
    It happens that anyone trying to visulize the second page of this page (except me)

    iscritti


    (so no login attempts) will get the page Access Denied …Allow requests…please provide you are not a robot with the math operation..etc. Even people already registered as users and for which I have allowed ips (even though their ips may have changed in the meantime). How can I avoid anyone being blocked trying to view the website on that specific page?
    Thank you very much!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The plugin is detecting a form submit (a “POST”) and it is assuming that the user is adding a comment or trying to log in.

    The javascript that you use to change pages is using a “POST” to submit form data to change the page.

    What you need to do is

    1) clear the stop Spammers cache
    2) clear the stop spammers log file.
    3) under stop spammers protection options uncheck “Automatically add admins to Allow List”
    4) under stop spammers allow lists remove your IP address from the allow list.
    5) log off wordpress.

    6) then reproduce the error. It should work. You also need to disable ad blockers. I noticed your site does not work at all if there is an ad blocker.

    7) Log back in.

    the stop spammers log report will have the reason that you were denied.

    There is a checkbox in stop spammers for every reason that you are getting blocked. Uncheck the check box that caused the problem.

    Lastly, get rid of all the plugins on you site. There is so much Javascript that is is a wonder the site works at all. Use the KISS principle – Keep is Simple and Smile.

    Keith

    Thank you kpgraham for taking time to answer my issue.
    I followed all the instructions til the seventh point, but I don’t understand the reason I was denied. Author too short? I cannot see nay protection option related to shortness of user…or maybe I’m looking in the wrong place. Please can you explain me?

    The log report says in 3 rows:
    2016/09/19 12:13:52 — 79.1.201.77 Marzia /wp-login.php passed Simple Aritmetic captcha
    2016/09/19 12:13:01 — 79.1.201.77 Marzia /wp-login.php Bad Cache:79.1.201.77
    2016/09/19 12:12:41 — 79.1.201.77 2 /iscritti/ author too short:2
    Thank you very much!

    Please do not use the plugin if you site is incompatible with the plugin.

    The plugin is incompatible with WooCommerce plugin. It will not work if you use a theme or plugin that uses a custom login. The plugin will not work if you use JetPack Protect.

    Keith

    I don’t use woocommerce, I use this plugin
    http://profileplugin.com/
    and I think it does use a custom login.
    If I understood the problem is the javascript that uses the POST form submit to change page?
    Can I limit the usage of your plugin only to specific pages like this ones:

    Login

    Registrazione


    Or the opposite, just disable it for the “iscritti” page with the pagination form.
    Thank you for any help!

    As the plugin stands now, there is no way to prevent one page from being ignored. In any case the page is a login page, which is the main reason why people use the plugin.

    Please uninstall Stop Spammers if you continue to use profile plugin.

    Keith

    I made a small change to the plugin. On the protection options screen you can uncheck the check for short email.

    This will fix problems for some people.

    The updated plugin is on my website on the beta test plugins page if you would like to download and try it.

    Keith

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘it stops everyone accessing pages’ is closed to new replies.