Support » Plugin: The Events Calendar » It shows error on setting

  • I just instelled The Events Calendar v4.9.12.

    When installed, I see the message below and I cannot setup the plugin or install more.

    ——–
    There has been a critical error on your website. Please check your site admin email inbox for instructions.

    Learn more about debugging in WordPress.
    ——–

    So I turned DEBUG and saw below message on //wp-admin/edit-tags.php?taxonomy=post_tag&post_type=tribe_events&page=tribe-common
    ——–

    Notice: Undefined index: the-events-calendar in /opt/bitnami/apps/wordpress/htdocs/wp-content/plugins/the-events-calendar/common/vendor/freemius/includes/class-freemius.php on line 14754

    Fatal error: Uncaught TypeError: Argument 1 passed to Freemius::get_api_user_scope_by_user() must be an instance of FS_User, bool given, called in /opt/bitnami/apps/wordpress/htdocs/wp-content/plugins/the-events-calendar/common/vendor/freemius/includes/class-freemius.php on line 20787 and defined in /opt/bitnami/apps/wordpress/htdocs/wp-content/plugins/the-events-calendar/common/vendor/freemius/includes/class-freemius.php:20801 Stack trace: #0 /opt/bitnami/apps/wordpress/htdocs/wp-content/plugins/the-events-calendar/common/vendor/freemius/includes/class-freemius.php(20787): Freemius->get_api_user_scope_by_user(false) #1 /opt/bitnami/apps/wordpress/htdocs/wp-content/plugins/the-events-calendar/common/vendor/freemius/includes/class-freemius.php(20826): Freemius->get_api_user_scope(false) #2 /opt/bitnami/apps/wordpress/htdocs/wp-content/plugins/the-events-calendar/common/vendor/freemius/includes/class-freemius.php(18016): Freemius->get_current_or_network_user_api_scope() #3 /opt/bitnami/apps/wordpress/htdocs/wp-content/plugi in /opt/bitnami/apps/wordpress/htdocs/wp-content/plugins/the-events-calendar/common/vendor/freemius/includes/class-freemius.php on line 20801

    • This topic was modified 1 month, 4 weeks ago by jjkim.
    • This topic was modified 1 month, 4 weeks ago by jjkim.
Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Contributor Andras Guseo

    (@aguseo)

    Not sure where this URL ending comes from:
    wp-admin/edit-tags.php?taxonomy=post_tag&post_type=tribe_events&page=tribe-common

    This url will give an error as a page like this does not exist.

    Could you please try to delete the plugin and reinstall again and see if that repeats? (I just tested a fresh installation and did not see any issues.)

    If the installation through the dashboard fails, then you can try to install manually instead:
    https://support.theeventscalendar.com/260486-Manual-Updates

    Hope this helps.
    Andras

    After install, when I go to events manager, I see that.

    I even cannot see the plugin section at my dashboard. So I deleted it through terminal because I cannot do it at plugin screen. Then I reinstalled and see the same result.

    Hello,
    We had the same error.
    It looks to be related to an underlying product they are using for their options panel.

    This plugin fixed it for us:
    https://github.com/Freemius/freemius-fixer/

    Hope this works for you.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.