Support » Plugin: Black Studio TinyMCE Widget » It says I’m missing the widget.

  • Resolved cptechdesigns

    (@cptechdesigns)


    I was working on my website earlier this morning, but I had to leave so I left my computer on until I returned like 30 minutes ago (which it is almost 9 PM now).

    When I came back, I noticed that the Black studio TinyMCE Widget is saying “missing widget”. I tried deactivating and then reactivating it, but it’s still saying it’s missing.

    I figured it wouldn’t be a big deal, so I tried to make a change on the page use that widget. WordPress displayed that “Page Updated” success message when I had hit “update” on the page; however, the changes will never appear on the actual website. I cannot add another one of these widgets because it’s not in the Widget Library in the Add Widget menu for the page.

    I’ve never had this problem before. I’ve been using this widget to edit my pages on literally all of my websites for at least a year now and this is the first time it has caused any problems. Literally from the first time I started using this widget up until about 30 minutes ago when I got back home, it’s been problem-free until now.

    What do do?

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Marco Chiesi

    (@marcochiesi)

    Hi @cptechdesigns,
    are you using some plugins that allows you to insert widgets in a page (i.e. Page Builder by SiteOrigin or WP Page Widget? Which version of WP and plugin(s) are you using?
    Please take a look at the troubleshooting guide included in our FAQ.

    I’m using Page Builder by SiteOrigin, running the latest version of that site builder and the latest version of BlackStudio, and WordPress version 4.8.2. So basically, all these and all my other plugins are at the latest versions.

    Also, I just tried to delete the BlackStudio Files from my File Manager in case it is corrupted (from what I read on a previous support post on here) and the problem is still here.

    If it matters, I’m using a child theme based on the “Flash” theme, but I doubt that’s the problem since I’ve had that for weeks now and the problem is just now happening.

    Plugin Author Marco Chiesi

    (@marcochiesi)

    It’s a bug on the latest release 2.5.0. Working on a fix a the moment. In the meantime you may download and install previous version 2.4.2 from here.

    I have the same problem. If I have to change widgets can anyone give this novice advice on the “how to” please? I have several pages where the widget is used.
    Thanks in advance.
    I just read your post of a few seconds ago. Thanks for the update. Looking forward to the fix. Great product.

    • This reply was modified 1 year, 8 months ago by  mabarnes11.
    Plugin Author Marco Chiesi

    (@marcochiesi)

    Version 2.5.1 fixes this issue. Sorry for any inconvenience.

    It’s working now, thanks!

    Hi there,

    Was just trying to update the plugin as our web staff can’t upload images for last 48 hours or so.

    Every time I do via the usual WP Dashboard however it says: Update Failed: “Could not create directory.”

    Please advise, thanks in advance and keep up the great work.

    Plugin Author Marco Chiesi

    (@marcochiesi)

    @rajkhedun Your problem seems to be a permission issue, totally unrelated to our plugin. Please check with your hosting provider.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘It says I’m missing the widget.’ is closed to new replies.