Support » Plugin: Freesoul Deactivate Plugins » It looks you have updated Freesoul Deactivate Plugins using FTP.

  • Resolved dapdap

    (@dapdap)


    Below message is showing.
    It looks you have updated Freesoul Deactivate Plugins using FTP. In any case to be sure everything is up to date, disable Freesoul Deactivate Plugins and then activate it again.
    I didn’t install by FTP.
    And Freesoul Deactivate Plugins is not working.

Viewing 5 replies - 1 through 5 (of 5 total)
  • My server is AWS.

    Plugin Author Jose

    (@giuse)

    Hi, @dapdap Thank you for opening a thread.
    When you activate or update Freesoul Deactivate Plugins it writes a MU plugin in the folder wp-content/mu-plugins. In that file, it’s declared the MU plugin version.
    In the main file included in wp-content/plugins/freesoul-deactivate-plugins.php it’s declared the plugin version.
    In a normal situation if those 2 versions are not the same it means you updated the plugin transferring the files in wp-content/plugins via FTP without updating the MU plugin included in wp-content/mu-plugins. This is the reason why I’ve decided to show that message if the 2 versions are not the same.

    Have you installed the plugin for the first time or this is an issue you have after the update?

    First of all, I suggest to do the following:

    – check you have the file wp-content/mu-plugins/eos-deactiavte-plugins.php. You can check the presence of this file via FTP, but also going to Plugins => Must-use (https://yourdomain.com/wp-admin/plugins.php?plugin_status=mustuse)
    – open via FTP the file wp-content/mu-plugins/eos-deactivate-plugins.php and report what you see at line 5 where it should be written define( ‘EOS_DP_MU_VERSION’,’1.7.4′ );
    – open the file wp-content/plugins/freesoul-deactivate-plugins.php and report what you see in at line 26 where you should find
    define( ‘EOS_DP_VERSION’,’1.7.4′ );
    – if you haven’t already disabled (without deleting) and reactivated the plugin, do it and tell me if you still have problems.

    Depending on the information you give me, I will tell you how to proceed to solve the problem.

    Hi,I have checked wp-content/mu-plugins/ folder.
    But eos-deactiavte-plugins.php file is missing.
    eos-deactiavte-plugins.php file has not been created.
    Is it due to permissions?

    Plugin Author Jose

    (@giuse)

    Hi @dapdap

    Probably it’s due to permissions. The folder mu-plugins should have permissions 755.

    To solve the issue you can copy the file:

    wp-content/plugins/freesoul-deactivate-plugins/mu-plugins/eos-deactivate-plugins.php

    and put it in:

    wp-content/mu-plugins/

    I will improve the self debugging in the next version. This problem could be automatically detected and the message could have shown the right instructions.

    Let me know if it works after copying the file.

    Thank you!
    I copy the file into wp-content/mu-plugins/.
    Now It will works well.

    • This reply was modified 7 months, 2 weeks ago by dapdap.
Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘It looks you have updated Freesoul Deactivate Plugins using FTP.’ is closed to new replies.