Support » Plugin: Index WP MySQL For Speed » It killed my site

  • Resolved Grzegorz.Janoszka

    (@grzegorzjanoszka)


    Hi, I have just activated the plugin and I see error message instead of the dashboard. In logs I see:

    *7726 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Uncaught mysqli_sql_exception: Access denied; you need (at least one of) the PROCESS privilege(s) for this operation in /z/wp-includes/wp-db.php:2056
    Stack trace:
    #0 /z/wp-includes/wp-db.php(2056): mysqli_query()
    #1 /z/wp-includes/wp-db.php(1945): wpdb->_do_query()
    #2 /z/wp-includes/wp-db.php(2695): wpdb->query()
    #3 /z/ext/index-wp-mysql-for-speed/code/imsfdb.php(120): wpdb->get_results()
    #4 /z/ext/index-wp-mysql-for-speed/code/imsfdb.php(161): ImfsDb->get_results()
    #5 /z/ext/index-wp-mysql-for-speed/code/imsfdb.php(102): ImfsDb->getInnodbMetrics()
    #6 /z/ext/index-wp-mysql-for-speed/code/imsfdb.php(48): ImfsDb->getStats()
    #7 /z/ext/index-wp-mysql-for-speed/code/admin.php(948): ImfsDb->init()
    #8 /z/ext/index-wp-mysql-for-speed/code/admin.php(927): ImfsPage->populate()
    #9 /z/wp-include"

    I have had WordPress running for years on this DB without a problem.

    I understand I may miss some permissions in DB, but I think the plugin should check for it instead just crashing the site.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author OllieJones

    (@olliejones)

    Sorry you’re having trouble with this. The code for that particular query (it’s on information_schema.INNODB_METRICS) catches an exception because we had the same problem in testing that you show here. Catching the exception has worked properly in many sites.
    But not yours, obviously.

    I guess the code should change to check the PROCESS privilege first rather than rely on exception handling. Stay tuned.

    Plugin Author OllieJones

    (@olliejones)

    Version 1.4.2 should correct this defect. Thanks for reporting it, and thanks for your patience.

    Thread Starter Grzegorz.Janoszka

    (@grzegorzjanoszka)

    Hi,
    It didn’t help, still white screen of death. This time the log message is:

    *95870 FastCGI sent in stderr: “PHP message: PHP Fatal error: Uncaught mysqli_sql_exception: SELECT command denied to user ‘user’@’localhost’ for table ‘user’ in /z/wp-includes/wp-db.php:2056

    Thread Starter Grzegorz.Janoszka

    (@grzegorzjanoszka)

    So before you released the update I added to my user the right for PROCESSES.
    Everything worked well with your plugin.
    Then the update came and it broke the site with the above error.

    I changed the indexes a couple of days ago and everything was fine with all the post that were already on the site. But today I published a new post and some plugins just fail to see it completely.

    My error log now sees:
    PHP message: PHP Fatal error: Uncaught mysqli_sql_exception: Can’t find FULLTEXT index matching the column list in /z/wp-includes/wp-db.php:2056

    I can’t even enable this plugin to revert the indexes!
    Please do something, as this plugin just broke everything.

    As far as I see it might be incompatible with contextual-related-posts plugin as the above error is dropped from this plugin.

    Thread Starter Grzegorz.Janoszka

    (@grzegorzjanoszka)

    I have just disabled contextual related posts plugin and everything is fine. So this database optimization did something, that newly created post had different indexes than the other ones. And contextual related posts failed on this very new post. Other plugins couldn’t finish their job.

    The problem is that your plugin completely breaks my site (white screen of death) and I can’t even recreate original indexes!

    Can you please check it? Take a wordpress blog, add contextual related posts to it, publish some posts, then activate your own plugin, optimize all indexes and then try to publish a new post. It will not work good and logs will be full of errors.

    Thread Starter Grzegorz.Janoszka

    (@grzegorzjanoszka)

    The CRP plugin author replied:

    It looks like the plugin deleted the FULLTEXT indexes of the plugin which is strange as it shouldn’t be doing that.

    Is it something that could help you fix the issue?

    Thread Starter Grzegorz.Janoszka

    (@grzegorzjanoszka)

    Hi,
    I am using PHP 8.1 and maybe the above errors have something to do with:
    https://php.watch/versions/8.1/mysqli-error-mode

    > It looks like the plugin deleted the FULLTEXT indexes of the plugin which is strange as it shouldn’t be doing that.

    I was also about to open a support ticket here, because indexes set by other plugins are getting killed: in our case, also related posts plugins, but ours are YARPP and RP4WP by Never5.

    Perhaps Ollie can enlighten us whether it’s possible to leave unknown indexes untouched?

    It’s probably impossible to build a library to maintain an index ecosystem, so probably the best thing would be to leave unknown things alone.

    Let us know if we can help if any way! – YARPP

    Thread Starter Grzegorz.Janoszka

    (@grzegorzjanoszka)

    I can’t do anything with this plugin, any activation of it kills my site and shows:

    *95870 FastCGI sent in stderr: “PHP message: PHP Fatal error: Uncaught mysqli_sql_exception: SELECT command denied to user ‘user’@’localhost’ for table ‘user’ in /z/wp-includes/wp-db.php:2056

    I can’t revert the changes done by this plugin, because it doesn’t work at all.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘It killed my site’ is closed to new replies.