Support » Plugin: Image Wall » It generates an error when you try to disable it!

  • Resolved raikit


    Hello, I tested the plugin. It is interesting! However, I can not disable the plugin. It generates an error when you try to disable it:

    Fatal error: Out of memory (allocated 99090432) (tried to allocate 53 bytes) in /mnt/web6/b1/xx/xxxxxxxx/htdocs/wp-includes/meta.php on line 571

    Best Regards


Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Parakoos


    Why would you want to disable it? (only kidding)

    I’ve never seen that one before. When you de-activate the plugin, it removes the random order meta data on all your images. I wonder if perhaps it doesn’t scale well? I’ve got a lot of images on my blog, and I’m on a shared (and very underpowered) host, and I’ve never seen this error before.

    How big is your site, and how many images do you have there?

    Plugin Author Parakoos


    For full disclosure, this is what the code does when you de-activate it:

    /* Clears all the Image Wall time hashes from all attachments. */
    function tmn_iw_attachment_hash_clear() {
    	$myposts = get_posts( array(
    		'post_type' 	=> 'attachment',
    		'nopaging' 	=> true,
    		'post_status' 	=> 'all',
    		'post_parent' 	=> null
    	) );
    	foreach( $myposts as $mypost ) {
    		delete_post_meta($mypost->ID, 'tmn-iw-hash' );

    I guess that there may be a scalability issue with the ‘nopaging=true’. I will see if I can replace this with a one-off hand-crafted SQL update call, which should scale without issue. It will take me a few days to do (busy busy) so please hang in there.

    In the meantime, don’t worry about the plugin remaining active. If there is no [image_wall] shortcode in your post or page, the plugin won’t add any CSS or JS files, so it won’t affect your site.

    Thanks for giving me a chance to fix this before leaving a bad rating.

    Thanks for your answer!

    I wanted to test it to make it possible later to take in the live mode after some adjustments. There are several thousand images ….


    WordPress 3.5

    Theme: Striking

    Maybe there’s a theme conflict. I will test it.

    Not smart of me, why I try to not to test our homepage. But since there are almost no pictures … hahaha ….

    I have patience. 😉


    Hello, there seems to be a conflict with the theme. I have now tested. I suppose that it is due to some internal theme scripts for image sizes. But I’m not the expert.

    Plugin Author Parakoos


    I’m glad to hear it! I will set this support item to resolved in that case. I hope you can track down the issue and sort it out with the theme developer.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘It generates an error when you try to disable it!’ is closed to new replies.