WordPress.org

Forums

Yet Another Related Posts Plugin (YARPP)
[resolved] It doesn't work with custom posts (7 posts)

  1. arkitecturahoy
    Member
    Posted 1 year ago #

    That's it. I've intalled and it doesn't work with custom posts types. A pity.

    http://wordpress.org/plugins/yet-another-related-posts-plugin/

  2. jeffparker
    Member
    Plugin Author

    Posted 1 year ago #

    Hi @arkitecturahoy. Did you follow the custom post type instructions in the readme.txt file? (The one found at http://wordpress.org/plugins/yet-another-related-posts-plugin/other_notes/ is cut off.)

  3. Drawer2
    Member
    Posted 1 year ago #

    Same with me. I don't want YAARP to show up with asides post type. I tried to uncheck the category and also the tag, but neither helps. They really wreck the aside type. They have big empty boxes. http://donnabarstow.com/

    I can see your instructions, but don't understand them. Which file do I change to stop YAARP for just asides? Thanks!

  4. stoi2m1
    Member
    Posted 1 year ago #

    Looks like everyone with CPTs is not getting the support they need. Some one actually helped me today and Im trying to spread the word.

    If you know of other threads about CPTs just place this link in there and try to help them too.

    Im new to this plugin and dont know much, but maybe if we put our efforts together we can help eachother.

    http://wordpress.org/support/topic/where-do-i-get-started-with-related-posts-for-a-cpt?replies=6

  5. jeffparker
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Drawer2. It sounds like you're not dealing with custom post types, but rather WordPress post formats, such as quote, aside, image, photo. Is that correct?

    Currently, we don't have a way to stop certain post formats from showing related posts. Per the FAQ, you could add <!--noyarpp--> to the HTML of any post where you didn't want related posts from displaying.

  6. Drawer2
    Member
    Posted 1 year ago #

    Thank you, stoi2m1 and jeffparker.

    I finally figured out that the only place it ruined the layout was on the index page, which I found somewhere is treated like archives in some themes. So I just unchecked that box for including archives and it immediately stopped appearing on the index page. Problem solved.

    Maybe it would help others if the plugin says archives = index page in some themes?

    Yes, I thought asides were custom post types. Foiled again!

  7. jeffparker
    Member
    Plugin Author

    Posted 1 year ago #

    Great suggestion, Drawer2! Glad it's now working for you.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Yet Another Related Posts Plugin (YARPP)
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.