WordPress.org

Support

Support » Plugins and Hacks » It doesn’t look like you’ve installed WP yet

It doesn’t look like you’ve installed WP yet

  • Hi all,
    Since 2.0 was released, I haven’t been able to upgrade WordPress simply because I kept running into the “It doesn’t look like you’ve installed WP yet.” error. I banged my head against the wall until I stumbled upon the resolution.

    This may have been covered in another thread, but I didn’t find anything to that affect after a few cursory searches.

    The logic in wp-settings.php I believe is incorrect, or at least should/could be modified. Specifically, I’m talking about line 121 where it states:

    $db_check = $wpdb->get_var(“SELECT option_value FROM $wpdb->options WHERE option_name = ‘siteurl'”);

    The problem is, if you are migrating to a new location, domain, or a new server, option_name may not equal siteurl at that time. So, if a match does not happen, the user is left thinking the upgrade process has failed, when in fact it succeeded.

    Case In Point:
    I, like a lot of people, prefer to do development in a way that does not impact the front end. So, when trying the upgrade, I would create a new sub domain called “foo” and install my code onto it. After upgrading, the error would show stating that it had failed.

    The above case would also be true if I was moving to a new server, and was accessing that page via IP (before DNS propagated).

    I’m not a developer, so I don’t know if that exception is needed for something else. But surely another sub-exception could be written to have a unique message stating “your upgrade has been successful. this site will display when accessed by $siteurl”

    In any case, I think a number of users are struggling with this error. It might be worth making it a tad easier for those of us who are migrating.

    My two cents.

    Geoffrey

Viewing 4 replies - 1 through 4 (of 4 total)
  • This topic seems to be related:
    http://wordpress.org/support/topic/62694?replies=13

    Hi Moshu,
    You are right, sorry I didnt see the thread.

    However, the question remains, could this be brought to the developers as an instance where the logic could be changed? I don’t believe the site should not load simply because the siteurl does not match the current location.

    Could it at least be decoupled so users who are moving systems or locations could have a way of checking prior to making the switch?

    There is some code change suggested in that topic by ringmaster (Owen Winkler), who is actually listed as “contributing developer” on the About page here…
    Also, there is a reference to the hackers-list discussion – that’s the mailing list where the developers meet.

    Ok, sorry for the duplicate thread.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘It doesn’t look like you’ve installed WP yet’ is closed to new replies.