It doesn't look like you've installed WP yet. (27 posts)

  1. Anonymous
    Posted 12 years ago #

    I have this problem during installation:
    when i run wp-admin/install-config.php, i put all parameters for DB, but it cannot create file "wp-config.php". So, as written in readme, i edit wp-config-sample.php and insert name, username, password and host of db and save it as "wp-config.php". When i try to run wp-admin/install.php, i have:
    "It doesn't look like you've installed WP yet. Try running install.php"
    What's the problem?

  2. WillM
    Posted 12 years ago #

    install.config.php doesn't work. Try searching for Spacemonkey's fix and re-installing.

  3. Anonymous
    Posted 12 years ago #

    i tried to replace Spacemonkey's files (install.php, install-config.php and upgrade-functions.php) but always that message occurs (i have also cleaned cache and re-upload all files). :(

  4. Spacemonkey
    Posted 12 years ago #

    That's odd, because install.php and all the files it uses (and even the files they use as well) don't contain the error message you're receiving. That message (AFAIK) is only located in wp-settings.php, which is not involved in the install process at all. Are you sure you're accessing wp-admin/install.php?

  5. jalal
    Posted 12 years ago #

    I got this message when I specified the table_prefix incorrectly.
    Correcting the table prefix took care of the problem.

  6. Steve Taylor
    Posted 12 years ago #

    Spacemonk, I'm getting the same error, and yes, it seems it's output via wp-settings.php. However, this is required by wp-config.php, which in turn is required by install.php.
    Has anyone solved this? (I've not touched the table_prefix, so I don't think that's a problem.)

  7. Anonymous
    Posted 11 years ago #

    I am facing a similar problem. I was able to successfully create the config file but when i try to run install.php this message is thrown up.
    It doesn't look like you've installed WP yet. Try running install.php.
    when i click on install.php, i get a page not found error
    pls help. Alternatively, from where i can pick up a previous working build.

  8. Anonymous
    Posted 11 years ago #

    When I try to access install.php through it's correct directory, it doesn't work and suggests "It doesn't look like you've installed WP yet. Try running install.php". The link it suggests is"wordpress/wp-admin/wp-admin/install.php" which is an error in the script.
    So unfortunately, I'm getting the exact same error.
    Very frustrating. I tried the nightly build too with the same result. I too manually edited "wp-config.php" before installation.

  9. junesix
    Posted 11 years ago #

    Based on your above link, it looks like you're trying to install WP on your own machine and not a hosted server. Are you sure you have all the requirements installed properly on your machine (PHP 4.1+, mySQL 3.23.23+)? Did you set up the database? You may want to read other threads in this forum on how to set up WP with IIS on your local machine.

  10. Anonymous
    Posted 11 years ago #

    I'd abbreviated the link, my apologies for misleading you. Oh, and I'm a different person to the one who originated the post. I however seem to be experiencing the same problem.
    I'm setting up on a hosted remote server, not my local system.
    I am installing it on a server with mySQL: 3.23 and PHP: 4.3.2. I've also created the mySQL database too.
    There really does seem to be an error in WordPress in that it doubles the path to "wp-admin" and for some reason won't execute the install script.

  11. Anonymous
    Posted 11 years ago #

    I'm having a similar problem - it appears that the install script is failing to create the required database tables, and when the install script checks for those tables it chokes somewhere in wp-settings.
    I'm looking for a fix at the moment and will post one if/when it's found!
    [php newbie, but 'professional' programmer]

  12. Anonymous
    Posted 11 years ago #

    I'm also having the same problem. Oddly enough, I installed WP on a different remote site a few days ago without any problems.
    Both sites are provided by the same company, however the successful install had a 'clean' db (no existing tables), while the one that keeps bouncing to the "It doesn't look like you've installed WP yet. Try running install.php" error already has tables in it...
    Also, I think the reason it is failing here: "wordpress/wp-admin/wp-admin/install.php" is because the link in the error message is document relative. Once it is clicked on once from the first error (/wp-config.php), if clicked again, duplicates the '/wp-admin' part...

  13. Anonymous
    Posted 11 years ago #

    Well, I dumped the tables from the working install, copied them over to the new db, and now everything seems to be fine. Odd that it didn't auto-generate the tables though, like the first time.

  14. Anonymous
    Posted 11 years ago #

    For what it's worth:
    I successfully installed last week, but today I encounter the same thing on my home machine.
    MySQL 4.02 PHP 4.3.7.
    When removing the $wpdb->hide_errors(); in wp-settings.php I can see the SQL that pops the error:
    Database error: [Table 'wordpress.wp_users' doesn't exist]
    SELECT * FROM wp_users
    It doesn't look like you've installed WP yet. Try running install.php.

  15. Anonymous
    Posted 11 years ago #

    Any ideas, anyone?
    I know I'm nagging, but an unresolved install issue means that potential users will go away. If I hadn't gone through a succesfull install and became a happy user last week I wouldn't try again after a failed installation...

  16. Mark (podz)
    Support Maven
    Posted 11 years ago #

    Sorry if this seems basic, but :
    - on the good install, where the mysql / php versions the same ?
    - have you tried a new database / starting over from scratch ?
    - What OS's are you using ?

  17. dpstk
    Posted 11 years ago #

    Well, uploaded the spacemonkey files but I get the error
    We're having a little trouble selecting the proper database for WordPress.
    Are you sure it exists?
    Your database name is currently specified as wordpress. Is this correct?
    On some systems the name of your database is prefixed with your username, so it would be like username_wordpress. Could that be the problem?
    when I point to install.php. The database is there and so is the user. wp-config is edited and everything... If I don't figure out this soon. I am going to ditch wordpress... it's given me nothing but heartache ever since I downloaded it 5 days ago.

  18. Anonymous
    Posted 11 years ago #

    On my failed set up I'm using:
    Xitami v2.5b5
    PHP 4.3.7
    On my running setup it's:
    mysql 4.0.x (not sure)
    PHP 4.3.x (not sure)
    Both Win2K.
    Now: Can anyone exaplain how come install.php eventually requires wp-settings.php (through ../wp-config.php), if wp-settings.php expects the installation to finis.
    Another question: wp-settings.php checks whether $_SERVER['PHP_SELF'] has install.php in it. I guess it checks weather it's being called in the install stage but in my case it contains the value:
    the value:
    /wp/wp-admin/install.php (which I guess we need to check)
    is in the ['SCRIPT_NAME'] ['REQUEST_URI'] variables.

  19. Anonymous
    Posted 11 years ago #

    Problem Solved!
    I've installed apache, and indeed it provides to full script name in $_SERVER['PHP_SELF'], unlike Xitami.
    I would suggest changing the check to use another server variable as mentioned above (unless it's a clear error on xitami's part...).
    Another issue I encountered is that step 3 failed to identify the correct blog location. It specified http://server instead of http://server/wordpressDirectory.

  20. Anonymous
    Posted 11 years ago #

    I'm having the same problem, i.e getting the message:
    It doesn't look like you've installed WP yet. Try running install.php.
    I'm installing on a remote host that's running:
    mysql Ver 9.38 Distrib 3.22.30, for sun-solaris2.7 (sparc)
    PHP 4.3.8
    There are other people running WordPress off of the same server so I'm not sure why I'm having problems
    I've tried replacing DB_HOST with the IP address of the server, but I get the same message as using 'localhost'. It also appears that WordPress has not created any tables in the process of setup.
    Any help would be most appreciated.

  21. Anonymous
    Posted 11 years ago #

    I installed at home server (running Xitami) just commenting the following lines in the file wp-settings.php :
    /*if (!$users && !strstr($_SERVER['PHP_SELF'], 'install.php')) {
    die("It doesn't look like you've installed WP yet. Try running install.php.");

  22. sidney
    Posted 11 years ago #

    I've been tracking this down and found a variety of solutions.
    Problem 1: $_SERVER['PHP_SELF'] is used in WordPress 1.2.0 but is not defined in all PHP installations.
    Problem 2: The link in the resulting error message is incorrect when WordPress is installed in a subdirectory instead of in the document root.
    You can ignore Problem 2 as it is just confusing things.
    Problem 1 fixes:
    First, you can confirm that this is your problem by displaying your PHP configuration using a test page named something like test.php that looks like
    That should display a lot of information about your PHP configuration, including a section titled PHP Variables that has an entry for _SERVER["PHP_SELF"]. If that entry says 'no value' this is your problem.
    If you are running the Xitami web server, put this in your php.ini file (it may be the default in newer versions of PHP, and this information was added to the Xitami install doc recently)
    If you are running PHP as a cgi that is invoked through an Apache redirect, perhaps using suPHP or suexec, then the above php.ini directive may fix the problem. Try it. I don't have access to a system set up that way and my Google results were less certain about that than it was about the Xitami case.
    If you are running PHP as a cgi indirectly through a shell script cgi that invokes the cgi version of PHP on a command line, you must ensure that all the environment variables that are listed in the CGI 1.1 spec are defined and exported before the call to PHP. Failing to define PATH_INFO will cause this particular error.
    Last ditch fix:
    If you are unable to get $_SERVER['PHP_SELF'] to be defined in your PHP environment, you can work around the problem by changing every instance of $_SERVER['PHP_SELF'] in the WordPress php files to say $_SERVER['SCRIPT_NAME']
    There are only a handful of those and that will fix the problem.

  23. Anonymous
    Posted 11 years ago #

    Have a look at your .htaccess file to make sure that it does not specify a different php setting. This was my issue. I had at one time modified the .htaccess file to make sure that gallery would work on FatCow's servers. Now that the default php version is correct, the .htaccess file was causing issues.

  24. rwclark
    Posted 11 years ago #

    I'm getting this same problem on a hosted UNIX environment (ocf.berkeley.edu to be specific). Sadly, phpinfo shows: _SERVER["PHP_SELF"] no value. I really don't feel like slogging through the workarounds tonight, but I'll update later if I can get anything to work. What a pain...

  25. danr
    Posted 11 years ago #

    Well, changing 'PHP_SELF' to 'SCRIPT_NAME' did just work for me. By my count, there were 13 files that had to be modified.

    Unfortunately, now themes don't seem to be working. I tried changing the themes in the admin section, but still nothing.

  26. danr
    Posted 11 years ago #

    I just re-installed, made the PHP_SELF to SCRIPT_NAME changes again, and now everything is working fine. I must have made a typo or something when making the changes.

  27. mathrm
    Posted 9 years ago #

    i have the same problem

    http://mathrm.110mb.com/wordpress/ <--- PROBLEM
    http://mathrm.110mb.com <--- phpinfo

    http://mathrm.phpnet.us/wordpress/ <--- WORKS fine
    http://mathrm.phpnet.us <--- phpinfo

    wp-config are the same. but some phpcore-server-configs are different. i think this is the problem.


Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.