Support » Plugin: Easy Appointments » It does not send messages. Help!

  • Hi, I have the easy appointments plugin installed.
    In “Settings” I have configured “send email to the worker” and “send email to the user”, however, by filling out the form and giving “send”, only mail arrives to the worker and not the user.

    To others, when the appointment is confirmed, the same mail arrives to the worker but not to the user.

    What I can do?

    Thank you.-

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Nikola Loncar

    (@loncar)

    Hi @guido0671 do you have custom field called email?

    Best regards,
    Nikola

    jcastillejo

    (@jcastillejo)

    Hello, I’ve the same error however I’ve e-mail custom field, error_log is equal

    ———— ERROR #6 ————
    TYPE: MAIL
    ERRORS: {“wp_mail_failed”:[“You must provide at least one recipient email address.”]}
    ERRORS_DATA: {“wp_mail_failed”:{“to”:[“”],”subject”:”Reserv 7″,”message”:”<p>canceled<\/p>”,”headers”:[],”attachments”:[],”phpmailer_exception_code”:2}}
    ———- ERROR #6 END ———-

    ———— ERROR #5 ————
    TYPE: MAIL
    ERRORS: {“wp_mail_failed”:[“You must provide at least one recipient email address.”]}
    ERRORS_DATA: {“wp_mail_failed”:{“to”:[“”],”subject”:”Reservaci\u00f3n 7″,”message”:”<p>pending<\/p>”,”headers”:[],”attachments”:[],”phpmailer_exception_code”:2}}
    ———- ERROR #5 END ———-

    ———— ERROR #4 ————
    TYPE: MAIL
    ERRORS: {“wp_mail_failed”:[“You must provide at least one recipient email address.”]}
    ERRORS_DATA: {“wp_mail_failed”:{“to”:[“”],”subject”:”Reservaci\u00f3n 6″,”message”:”confirmed”,”headers”:[],”attachments”:[],”phpmailer_exception_code”:2}}
    ———- ERROR #4 END ———-

    ———— ERROR #3 ————
    TYPE: MAIL
    ERRORS: {“wp_mail_failed”:[“You must provide at least one recipient email address.”]}
    ERRORS_DATA: {“wp_mail_failed”:{“to”:[“”],”subject”:”Reservaci\u00f3n 6″,”message”:”<p>pending<\/p>”,”headers”:[],”attachments”:[],”phpmailer_exception_code”:2}}
    ———- ERROR #3 END ———-

    ———— ERROR #2 ————
    TYPE: MAIL
    ERRORS: {“wp_mail_failed”:[“You must provide at least one recipient email address.”]}
    ERRORS_DATA: {“wp_mail_failed”:{“to”:[“”],”subject”:”Reservation 5″,”message”:”confirmed”,”headers”:[],”attachments”:[],”phpmailer_exception_code”:2}}
    ———- ERROR #2 END ———-

    ———— ERROR #1 ————
    TYPE: MAIL
    ERRORS: {“wp_mail_failed”:[“You must provide at least one recipient email address.”]}
    ERRORS_DATA: {“wp_mail_failed”:{“to”:[“”],”subject”:”Reservation 1″,”message”:”confirmed”,”headers”:[],”attachments”:[],”phpmailer_exception_code”:2}}
    ———- ERROR #1 END ———-

    Please help me, is

    Dmitriy Egorov

    (@egorovbyegorov)

    Hi Nikola Loncar. I have little problem with your plugin, can you help me please?!
    I got this error
    ———— ERROR #1 ————
    TYPE: MAIL
    ERRORS: {“wp_mail_failed”:[“You must provide at least one recipient email address.”]}
    ERRORS_DATA: {“wp_mail_failed”:{“to”:[“”],”subject”:”Reservation 1″,”message”:”confirmed”,”headers”:[],”attachments”:[],”phpmailer_exception_code”:2}}
    ———- ERROR #1 END ———-

    if it will be help you, i have a installed plugins:
    Advanced Custom Fields Version 5.8.0 | By Elliot Condon
    Contact Form 7 Version 5.1.3 | By Takayuki Miyoshi

    Plugin Author Nikola Loncar

    (@loncar)

    @jcastillejo @egorovbyegorov

    You must have at least one custom field type email in form or field with name email.

    In both logs {“wp_mail_failed”:{“to”:[“”], this “to” section is empty.

    Best regards,
    Nikola

    @loncar
    Thanks so much for the quick response. True, I did not understand where to write an email. I registered email in all fields that are relevant for this input and which are located in the settings menu of this plugin, but the error remains. But okay, it doesn’t work at work. I have a serious question regarding plugin settings. I read many articles on the forum in the hope of finding an answer to my question, but I never found the answer.
    QUESTION!
    How can I increase the number (requests || registrations) per event created?
    (I mean, when I create (event || meetup) for a certain time, for example (07/17/19, 12: 00-13: 00), only 1 person can enroll in this (event || meetup). I need increase this number by at least 500. Please tell me how I can implement this?
    After reviewing your code (P.S. I want to note the excellent and competent development of the plugin.) And as I understood from what was written, the number of records for an event is generated from the number of events themselves. But when you try to change these values ​​hard, nothing changes.

    @loncar
    The problem with errors regarding email decided! Just the error logs of the old installation were recorded in the database and they took the old errors out of line and were displayed! Solved the problem by deleting these logs from the database! When updating, no bug was gone!
    I hope this helps someone!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘It does not send messages. Help!’ is closed to new replies.