Support » Plugin: SG Optimizer » it doens’t work if you have installed Pods

  • vs999

    (@vs999)


    It doesn’t work if you have installed Pods, indeed my website wasn’t getting cached I had to disable every plugin and I found out that it has a conflict with Pods.
    I contacted the support, here what they said:

    We understand. Regrettably, sometimes a combination of Addons/Plugins could cause such issues.
    It is great, that you have a working solution.

    That is it, My “solution” was to go back to wp fastest cache which neve caused me a problem.
    I waisted a whole day trying to make this plugin work, I hoped they would at least try to fix the issue with Pods, but it didn’t happen.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Stanimir Stoyanov

    (@sstoqnov)

    SiteGround Representative

    Hey @vs999

    The problem is related to the Pods plugin and how they use sessions.

    When a session is started, a no-cache header is sent to the server, which means that our plugin and servers respect this header and do not return cached content.

    By default, the PHP and WordPress don’t send such header, but when a session is started, the header I mentioned is required.

    The reason for such header clear: If a session is cached, it will be sent to all other visitors, which may cause issues with payments, orders, etc.

    You can read more about session_start and no-cache header here:
    http://khaidoan.wikidot.com/php-session-start-and-cache-control-header

    And here is where the Pods plugin starts the session:
    https://plugins.trac.wordpress.org/browser/pods/trunk/includes/general.php#L2588

    Regards,
    Stanimir

    Moderator Jan Dembowski

    (@jdembowski)

    Forum Moderator and Brute Squad

    @sstoqnov This isn’t a review that needs reporting. This is feedback, you replied well, The End.

    *Drinks coffee*

    Except this part.

    I will appreciate it if you remove this review because the problem is with Pods plugin, not Sg Optimizer.

    Do not ask for that again, OK? Really please do not. Review here are feedback, nothing more and nothing less. While it isn’t pleasant to get a 1 star review, this is not an online Mega Store, this is not an online Auction Letter-Bay auction site.

    Had someone attacked you in a review then yes, that would need a moderator to do something. This is not that so please just accept the feedback and move on.

    Just a heads up, we’re working on this in the next feature release for Pods where sessions will default to off but in a backwards compatible way for those people who needed them. Coincidentally, this was already planned so I’m glad we have this already in motion.

    You can workaround the session starting using this snippet in your wp-config.php:

    define( 'PODS_SESSION_AUTO_START', false );

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘it doens’t work if you have installed Pods’ is closed to new replies.