WordPress.org

Support

Support » Plugins and Hacks » "It appears that we are having some trouble setting up Shareaholic…"

"It appears that we are having some trouble setting up Shareaholic…"

  • Marco
    Participant

    @looimaster

    On my localhost WAMP I see this message permanently: “It appears that we are having some trouble setting up Shareaholic for WordPress right now. This is usually temporary. Please revisit this section after a few minutes or click “retry” now.”

    So, this plugin doesn’t work at all.

    http://wordpress.org/plugins/shareaholic/

Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Author Shareaholic
    Participant

    @shareaholic

    Hi Looimaster, One usually gets this error when our servers are facing unusually high traffic and may last for at most a few minutes. Were you able to setup? Do let us know!

    The Painted Hive
    Member

    @the-painted-hive

    I’m having this same problem. Installed on WAMP and have been unable to ‘set it up’ for about an hour now. Each time I try to access the settings page I get the ‘retry’ pop up window. Any advice? Thanks.

    Plugin Author Shareaholic
    Participant

    @shareaholic

    @the Painted Hive

    Based on cases we’ve come across in the past, a couple of things to check:

    – Are any of your WordPress related MySQL tables corrupted? (wp-options in particular)
    – What is the localhost URL of the WP install? We can check whether our domain validation is too strict. Can you add the domain here? https://shareaholic.com/publisher_tools

    Marco
    Participant

    @looimaster

    It still doesn’t work for me neither unfortunately.

    Good advice: instead of asking average non-tech-savvy users if their wp-options database table is corrupted (which is very unlikely to happen), why not write this plugin properly?

    Sorry to say that but it’s overcomplicated and many people think that it’s just broken. I really respect your work and I would love to use this plugin and recommend it to other WordPress users but let me say this straight: it needs to be corrected before this can happen. I hope that you’ll act upon this comment.

    Good luck!

    Plugin Author Shareaholic
    Participant

    @shareaholic

    @looimaster

    To clarify, there is absolutely no reason why Shareaholic would corrupt your wp-options table. We use very standard inbuilt native WP functions to interact with mysql, following WP best practice.

    What we HAVE seen is the wp-options table does get corrupted for a very small number of users, for whatever reason, before they even installed Shareaholic and then Shareaholic or any plugin that needs to write to wp-options does not run properly. Corruption can happen for a variety of reasons, including poorly written plugins (which, there are a lot of).

    Surprised us as well.

    For some plugins, if the table is corrupt it will be very apparent and for others it will slip by. Depends on how much a plugin uses wp-options and for what.

    If you need help checking wp-options, just let us know and we can provide simple instructions on how to do so. We’re happy to check directly as well. We have done this for our users, but will need admin access to your install. The good news is that even if it is corrupted, it is very easy to fix.

    Also note, Shareaholic is used by hundreds of thousands of sites. So even if less than 0.1% of our users run up against an issue, it can add up to many users. I can’t imagine wp-options gets corrupted for very many users, but we’ve seen it at least once in the past week which prevented Shareaholic from getting installed. It is SO non-obvious, that it made sense to at least mention it here.

    ***

    ps – it would be great if you could try:

    – What is the localhost URL of the WP install? We can check whether our domain validation is too strict. Can you add your localhost domain successfully here? https://shareaholic.com/publisher_tools

    bobeedesign
    Member

    @bobeedesign

    It looks like it does have to do with the restrictions placed on URLs. For instance I am developing locally using MAMP and I’ve set my local url to resourcephx:8888, which was rejected. However when I typed a fake URL of localhost:8888 it took. It might be that you are validating the url to require a .com/.net or suffix.

    If you could loosen those restrictions that would be awesome! Thanks! 🙂

    Marco
    Participant

    @looimaster

    @shareaholic

    Relax. I didn’t mean that it breaks wp-options. In fact I think that it’s very unlikely that this or any other plugin would break wp-options in any way. How would a plugin do that if 99% of them are using simple update_option()?

    By “properly” I only meant that I can’t use this plugin on WAMP, localhost, when I’m for instance on a plane or in a train because it requires Internet connection. This is invalid to me. Unnecessary complication.

    My localhost is using IP address like: 123.123.0.1 where “123” are like 192 or other appropriate for the network that I’m currently in. Changes depending on LAN.

    Plugin Author Shareaholic
    Participant

    @shareaholic

    Hey Guys, we’re looking into relaxing the validation requirements.

    In the meantime, we recommend updating your host file. How-to instructions here.

    add something like this:

    123.123.0.1 local.com
    Marcelo Pedra
    Participant

    @kent-brockman

    Guys, just to add to the discussion, I’m not working on a localhost and yet my production website is showing the “It appears that we are having some trouble setting up Shareaholic…” message from time to time when I try to tweak the plugin options…
    I’m afraid that if the related content and so are stored in your end, some day may happen to lost the connection for a longer period of time and let my website in a mess.
    Any thoughts?

    @marcelo,

    Please check your web host documentation to see if there are restrictions on server-to-server connections. If this is implemented by your web host, many times server-to-server connections are disabled by default, which would cause you to receive this error on our settings pages.

    You may need to add US servers to your whitelist and/or our domain: shareaholic.com. This problem would only affect you when trying to access the plugin settings via your WordPress Dashboard, but will not impact any frontend usability.

    Marcelo Pedra
    Participant

    @kent-brockman

    Hello there Celeste. What php method/protocol does your plugin to do the connection from server to server? I own a VPS, so if any recommended php settings are available, I can test it right away.

    Also, if you can tell what the IP range of your servers are, I can whitelist them both in my server firewall and in Wordfence plugin.

    BTW, is there any possible incompatibilities with Wordfence plugin?

    Plugin Author Shareaholic
    Participant

    @shareaholic

    Hi Marcelo, here are some more details:
    https://blog.shareaholic.com/shareaholic-hosting-faq/

    Let me know if this helps!

    Marcelo Pedra
    Participant

    @kent-brockman

    @shareaholic: not at all. No matter. What I’d like to ask is.. when this connection from server to server is not possible, what’s the worst thing that we can notice happening with the counters in the websites? related content broken? related content “update-less”?

    Marcelo,

    Without a server-to-server connection between the plugin settings and our server, the problem will only affect your ability to edit your settings on the Available Apps screen as it cannot pull up the settings stored on the cloud, which you will find under the Site Tools page when logged into your Shareaholic user account. The ability for your WordPress access panel to make a server-to-server connection does not affect frontend usability. Your settings will still be applied when the apps load on your site, because your site itself can load external resources. The plugin injects the code into your site that is used to pull in your settings to render the apps.

    Anyone having trouble with the Retry prompt and running WordPress under localhost, make sure you have cURL enabled so that your environment is setup to make server-to-server connections.

    Here’s a thread with some information on how this can be done in WAMP, and here’s another thread that specifically concerns XAMPP.

    Hope this helps someone!

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘"It appears that we are having some trouble setting up Shareaholic…"’ is closed to new replies.