Support » Plugin: W3 Total Cache » It appears Minify URL rewriting is not working – EC2 Ubuntu/Apache

  • Resolved bheadrick


    I’m on the latest version of WP and W3TC. \

    I’ve tried disabling all other plugins.

    Page cache rewriting seems to be working fine, as does the standard url rewriting for WP “pretty permalinks”

    I’ve got rewrite logging on and error logging set to “debug” but the only errors I get when trying to load the minified css/js with minify URL Rewriting turned on is just that those files don’t exist.

    I even turned off all modules except for minify to make sure that there wasn’t some kind of conflict with gzip somewhere.

    The strange thing is that rewriting seems to be working some of the time, just not all the time (though the error never actually goes away)

    When I say it’s “working” i mean when I load the page and see the reference, remove the ?file= from the url and sometimes the file loads up, and sometimes I get a 404.

    I’ve got a few other sites on shared hosting where this plugin works flawlessly, so I know it’s something with my server config, I’m just not sure what.

    The proper .htaccess file is in the minify directory and I even went as far as setting the permissions on it to 777.

Viewing 5 replies - 1 through 5 (of 5 total)
  • I don’t know if it’s the same issue but if I enable minify it consistently breaks my site with a similar setup (EC2 Ubuntu/APC) but when I enabled debug for minify it magically starts working. The only error I could find was this in the apache error log:

    [Fri Nov 02 16:22:54 2012] [error] [client IP_ADDR] PHP Warning: apc_store(): Potential cache slam averted for key ‘w3tc_www.mysite.com_1_minify_files_5049ae4694f0d74eb43246089dce1d05’ in /var/www/sites/ on line 43

    W3TC / Page (APC), Minify (APC), Object (memcached), and Browser caching / Apache 2.2.22 / PHP 5.3.10-1ubuntu3.4

    I’m not currently using APC or object caching, and minification itself works fine – it’s just the rewriting that’s not working

    I turned on debug, but it just told me what files were being added to the minify file and didn’t have any impact on whether anything worked.

    I am having similar issues,
    as well, when I turn minify off completely after having it set to on, (and empty the cache) my page is still trying to load the minify css file returning a 404.

    I think that w3 minify is not ready for prime time, I’ve spent a few hours testing various configurations, auto minify and manual and turned off. Still getting a 404 for the css.

    I’m ready to reinstall the plugin then leave minify turned off, and use though that plugin works well, it doesn’t automatically include your theme css file, so you have to manually enque the theme css file.

    I had some success on one server, but not the other. I added this to my http.conf file:

    <Directory /wp-content/w3tc/min>
    Options FollowSymLinks
    AllowOverride All
    RewriteEngine On

    and suddenly, minify rewrite was working!

    On another server, however, that did not help. I suspect that there’s something being explicitly declared in the master conf file that’s preventing this from working – I’m just not sure what. (this is a server that was not set up by me.

    ooooohhhh yeeeaaahhh.

    my problem was that the apache.conf file had the primary .htaccess file defined explicitly, thus preventing any other .htaccess files from being used. after adding “AccessFileName .htaccess” to the config file for the site I was working on, everything magically worked.

    The downside is that the minified js file is over 40k, which is well above the recommended 25k. Page is loading slower with files minified – even while using cloudfront – than without any minificaiton.
    It would be nice if auto minify automatically split the files to prevent that. Instead, I’ll have to manually configure minification to break the files up.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘It appears Minify URL rewriting is not working – EC2 Ubuntu/Apache’ is closed to new replies.