Support » Plugin: WP2Static » it always fails during initial crawl

  • Resolved dreamsoft


    the plugin seems great – but I can’t manage to make it work.
    it always fails during ‘Crawling initial file list’
    I even increased maximum execution time, but, after a long wait, it still fails.
    Wordpress is updated, and I run the latest PHP and all.


Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author WP2Static Team


    Hi @dreamsoft,

    Thanks for trying the plugin, I should be able to help you get it working.

    We have a few ways to debug this in 6.6.5, first, we can try re-running with Debug Mode enabled (Advanced tab). This will result in an Export Log, which you can view from the Logs tab.

    In the case of PHP memory being exhausted, this will not show in that log, but should show in your server’s web/PHP logs if they are enabled. In the case of PHP memory limit being exhausted, we can try increasing the memory_limit option within your PHP settings (same place as the max_execution_time setting. It’s usually set to 128M by default and most large sites will complete export by doubling that.

    May take a little trial and error to get the right settings for your particular setup, but there are a few other things we can try if those don’t work.

    Please let me know if those help or if any more info comes out of the logs.



    I have just installed this on a new wordpress install.

    First, if you get the warning about curl you need…


    For it to crawl your site you need…


    And to compress your files…


    This was on a Debian 9 install using php7.3

    Plugin Author WP2Static Team


    Hi there,

    Closing this issue due to inactivity / assumed resolution. Please re-open to continue the discussion.

    You may also try an early development release of version 7, which brings a lot of fixes and some nice new features:



    @wiliam_syd @dreamsoft check if you have the php-xml module installed.


Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.