Support » Localhost Installs » Istall WP using MAMP failing all the time

  • Hello friends,
    I am totally new to this and my quest for the installation of WP failed miserably on both, my Synology NAS and on my own desktop.
    I will stay with the MAMP experience. Servers both running, the install files placed properly< I am trying to do everything simple and using default settings. Error sticker comes no matter what I do. I can’t figure, what am I doing wrong in such a simple operation?

    • This topic was modified 2 years, 5 months ago by  Steve Stern.
Viewing 4 replies - 1 through 4 (of 4 total)
  • Damon Cook

    (@colorful-tones)

    Hi vizavladimir,
    In order to try and help can you please provide more details please. Like:

    • Are you using MAMP or MAMP Pro?
    • Which version are you using of MAMP?
    • What steps are you taking to install WP, and where does it fail?
    • What is the error you’re receiving? Is it a MAMP error, or WordPress-specific error? A screenshot might be helpful.

    Thanks, and hope you’re enjoying your day!

    Damon,
    I am using MAMP just downloaded from its site. No Pro.
    The very first step failing with the error sticker. I have screenshots but cannot figure how to post them here.It is a WP “Error Establishing database connection” with standard text. I do follow text, checking everything but cannot find where is my initial configurations are, since I never had anything entered anywhere yet.
    The day is far from being enjoyable, unfortunately. The more I am dealing with it the more frustrating the experience.

    • This reply was modified 2 years, 5 months ago by  vizavladimir.
    Damon Cook

    (@colorful-tones)

    How are you installing WordPress? I can’t remember, but doesn’t MAMP allow you to do a one-click install? or maybe that is only MAMP Pro.

    If you’re doing it manually then check your wp-config.php file for the database credentials to make sure they’re matching with your desired local database. See here for more info: https://codex.wordpress.org/Editing_wp-config.php#Configure_Database_Settings

    I have the same problem.
    Wordpress presents a page to input hostname, username, password, etc…
    I input the details correctly and an error page appears asking if the details are correct and if the server is running.
    Both these things are fine to my knowledge, i have tried many times over.
    Any ideas as to what is going on?

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Istall WP using MAMP failing all the time’ is closed to new replies.