WordPress.org

Forums

Q and A FAQ and Knowledge Base for WordPress
[resolved] Issues with W3 Total Cache Combine & Minify (3 posts)

  1. Xcellence IT
    Member
    Posted 2 years ago #

    Hi,

    I've configured W3 Total Cache to combine & minify CSS. This cause FAQs to break... they are no longer working correctly on FAQ pages. When you click on title, the answer text doesn't appear.

    Moreover, on another page where I have used only one category faq, it was set to open by default and have the same issue.

    Can you guys advise how to fix this. This is very important for us to fix as we can not sacrifice speed. I think no one wants to sacrifice on the speed... so you can look into this and advise how to fix this.

    Awaiting your response.

    http://wordpress.org/extend/plugins/q-and-a/

  2. l0gan0
    Member
    Posted 2 years ago #

    @Xcellence - I had the same problem. You need to go to your W3 Cache settings and specify that you don't want the q-and-a js/css files to be combined or minified. Then empty your cache/cdn and try again.

    I recommend disabling cache/minify for logged in users/admins so that you can identify problems spurring from that.

  3. Dalton Rooney
    Member
    Plugin Author

    Posted 2 years ago #

    I've found the problem with minification usually comes from the order of the javascript. I've never had W3TC minification work properly for me on any site I've used it on. I prefer to concatenate my scripts manually for this reason.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Q and A FAQ and Knowledge Base for WordPress
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.